Problems with new Bluerov

After assembly I updated software as in guide. When I updated the Pixhawk I did that with a Usb cable from computer to pixhawk and when the update had finished it connected with the Qgc.
Now when I try to connect with theter and all it does not connect with Qgc, only the camera is connected.
I have tested with new cables between pixhawk and raspberry and I have made exceptions in firewall etc.
What can be wrong ??

Hi @oxtox,

Have you followed all the troubleshooting steps? If so, what were the results?

Note that the Companion software is being replaced by BlueOS, which it may be worth trying instead :slight_smile:

I have Done some of the test and I have no Pixhawk autopilot entry on the system page, I get an answer when I ping it, and I have tried with other cables.
Will continue testing in a couple of days.

Thanks !

1 Like

If it’s not being detected then it won’t be possible for mavproxy to connect to it. There’s likely an issue with the device/setup (e.g. invalid/damaged Pixhawk firmware, insufficient power, bad cable, fried Raspberry Pi USB port, etc).

I have done some more testing now and I can´t get it to work.
I have tested other cables, BlueOS etc.
When I try to connect the Pixhawk directly to my laptop I only get it connected with Qgc somtimes and most of the times not.
Can I expect the Pixhawk to be broken in some way or can I do more tests ?

If that only works sometimes then I expect it’s a hardware / electrical issue, so my main suspicions would be

  • the cable is dodgy
  • the micro-USB connector on the Pixhawk is dodgy
  • your laptop’s USB connector is dodgy

If changing cables and trying different USB ports on your computer don’t help then I’d recommend you contact to sort out a replacement. It would be helpful if you can link them to this post, and if possible also provide the order number / date :slight_smile:

Ok, Thanks !!

I have now received a new Pixhawk, can you please advice how to procced with this matter, shall I install Ardusub on the new Pixhawk and then replace the old and hopefully broken one with the new one and then start up the ROV and if ok continue with calibration etc, is this the correct way ?

Thanks Peter

Hi @oxtox,

Yes, if the Pixhawk was in fact the problem then that should be fine. If that doesn’t fix things then the issue is most likely with a different part of the system.

The new Pixhawk solved the problem and now I have a new one, when I tried to setup the thrusters, thruster nr. 6 will just hardly start rev. it rev:s for maybe a second or two with ca 10-100 revs/min maximum then it beeps 2 times and it stops, all other thrusters works well.

Glad to hear it :slight_smile:

Is this testing occurring in the water, or in air?

The propeller should turn freely by hand (when the vehicle is off) - if it’s not doing so then I’d recommend you check for damage or material buildup on the propeller, and see if anything is caught under / stuck in the rotor. If that’s not the case then please try testing in water and seeing if it works as expected. If not I’d recommend contacting the support email to determine what’s wrong with your thruster - if it’s defective then we should be able to sort out a replacement or refund as relevant, although that won’t be possible if it’s been damaged due to excessive high throttle use in air.

Testing has been done in water, the thruster runs freely and I cant see any rubish in it

I was more thinking some stiff mud or some fishing line or similar, but ok, I’d recommend contacting support as mentioned above.

Will do!
Thanks Eliot !

1 Like

Hi Eliot
A cable was loose so now are all thrusters working and I have done all calibrations etc.
When I try to run the ROV in my pool nothing happens when I push forward etc on the joystick, buttons work but no thrusters, depth hold, stabilize and lights, arm/disarm and gain works.
The x/d button on back is set to X (tried D as well)
The Qgc says joystick connected and enabled.
Thanks !

Hi @oxtox, sorry for the delay on responding to this.

I’m not sure what would cause something like this, unless

  • there’s a failsafe preventing you from arming (which there should be clear messages about, and the vehicle should stay disarmed)
  • your joystick isn’t working properly (in which case I expect the joystick calibration should fail)
  • the motors are not connected or assigned correctly (in which case some or all of them likely wouldn’t be working at all)

Can you confirm that the joystick calibration is complete, and perhaps try resetting the parameters?

The joystick is calibrated and I can arm the Vehicle , I have tried to calibrate again, I can run the thrusters manually from Qgc.
Resetting parameters, no difference
I can not tilt the lights either.