Problem updating ardusub 3.5.4 to new version

I’ve got a BlueROV2 with Companion Soft v0.0.17 and Ardusub v3.5.4 installed.I’ve tried to update Companion but no Update button appear so, I think that the version of Companion is not a problem.

I’ve tried to update ardusub software through the “Pixhawk Firmware Update” section that can be found in but I get the following error message:

Downloading stable ArduSub firmware from
<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581)>
Error downloading firmware! Do you have an internet connection? Try ‘ping

I’ve checked the internet connection, and all is OK. Also, I’ve tried to download the file ArduSub-v2.px4 to my PC using the URL mentioned in the error message but this URL is not valid so, I can’t download the file…

Can someone tell me how to download the file that I need to update Ardusub?

Best regards, and thanks in advance…


Hi @danicas, welcome to the forum :slight_smile:

This is in fact a Companion Software issue (the latest stable version is 0.0.31, but it’s possible 0.0.17 might have had some issues with the standard updating process, or is just old enough that it ended up being broken by something outside our control). Note that our original Companion Software is no longer being developed - I’d recommend checking out BlueOS instead, which is a ground up rewrite.

For future reference, all our recommended software and firmware versions are collected together in our technical reference :slight_smile:

If at some point you do in fact want or need to manually download a pre-built ArduSub firmware, you can do so from and selecting your flight controller board.

Thank you very much Elliot!!!

I’ve moved to BlueOS and now all is OK!!!

Best regards,

1 Like