Port streaming trouble

How can I change the port of the QGroundControl stream? I’ve tried changing it on blueos.local, but the video keeps directing to QGC after I open the app again. My goal is to run GStreamer and send the UDP stream to QGC and another UDP port to another computer. However, I still have to close QGroundControl to open GStreamer and close QGroundControl to open GStreamer, even if I set a different port on blueos.local. Seems like whatever port that i put in will be automaticly readed by the QGC.

Thank you in advance.


Hi @Aldren, welcome to the forum :slight_smile:

By default the BlueOS video manager presents any configured video streams via MAVLink, which is how QGroundControl finds out about them regardless of ports.

If you want to disable that you can

  1. enable Pirate Mode
  2. go to the video manager
  3. click the blue pencil button to edit the stream configuration
  4. click to expand the “extra configuration” section at the bottom
  5. select “Disable MAVLink”
  6. click “APPLY”

Note that QGC does also have a hardcoded check for video streams at port 5600, so you’ll need to use some other port than that.

Note that the BlueOS video manager can direct one incoming stream to multiple targets, so it may not be necessary to manually set up a gstreamer redirection on your topside computer if your other computer is reachable by the vehicle’s onboard computer (e.g. if it has an IP address on the same subnet, or is on a shared ZeroTier network or similar).