Home        Store        Docs        Blog

Pixhawk is not bootloading or found in lsusb search


(Jeremy Tushnet) #1

Hello,

I am trying to setup a blue Rov 2 system and have been having some difficulty getting the firmware to load on the pixhawk. I keep getting this error message.

Flashing Pixhawk…
Loaded firmware for 9,0, size: 830044 bytes, waiting for the bootloader…
Timed out trying to catch bootloader!
Please try again.
Waiting to restart mavproxy…
Restarting mavproxy
Complete!

I have seen a similar issue from a post back in April of 2014 here:

Where in that thread the user was told to run lsusb to see if the pixhawk is connected to the rasp pi. He is able to see the pixhawk, but I’ve still been unable to as seen in the picture here.

I’ve tried resetting the mavproxy, but it gave the same error as the other user. And I have tried several usb cables. This one has worked in the past for the Blue Rov as well.

Is my pixhawk busted or is there some sort of software mishap?

Thanks.


(Willian Galvani) #2

Hello Jeremy,

Try running dmesg -w and while it runs, unplug and plug the Pixhawk.
If there is a usb communication error, it should show there.


(Jeremy Tushnet) #3

It gave me this message.

Does this mean that everything is fine?


(Jeremy Tushnet) #4

When trying to flash pixhawk, it didn’t seem to work again.

When using lsusb again, it still hasn’t found the device that the troubleshooter says it should. Using the ls /dev/serial/by-id/* function also turns up nothing as it says it cannot access this file/directory.


(Jeremy Tushnet) #5

I don’t know if this helps narrow down the issue but I’ve also tried to update the firmware on the pixhawk directly through qgc with a usb cable to my computer and it starts the upload process then cancels around 10 seconds later saying that it failed.


(Patrick José Pereira) #6

Hi Jeremy,

It appears to be a problem with your usb connection, try to replace the cable or to use another usb port in the raspberry.


(Jacob) #7

Please contact support@bluerobotics.com with your order number and reference this thread.