Newton Gripper R3 doesn't work; but the R2 does

I have a robotics team using the Newton Gripper R3 on their MATEROV this year. Students worked to install the gripper and test it using their BlueROV2 electronics enclosure. The R3 failed to operate. They switched a R2 from a previous ROV build and it worked just fine. This eliminated the electronics/ controls/ software in our minds due to the R2 coming off a working ROV (again tested prior to the swap).

Students then installed the R3 onto the previous years ROV (R2 was working earlier) and the R3 still didn’t want to operate (open/ close).

So we have an R2 that works on both ROV systems and the R3 that won’t work on either. All software is current as well as trying out the BlueOS. Any suggestions, settings or anyone experience something similar? - I’ve sent a memo to my order in hopes to have some light shed on the issue by BlueRobotics too.

Thanks in advance! - I’ll share your responses with the team.

Hi @pgraven,

According to the Revision History in the Newton Gripper Technical Details, the only change from R2 to R3 was swapping to WetLink penetrators. R3 didn’t change the communication mechanism or electrical specifications, so assuming it’s being plugged in correctly there’s most likely an issue with the gripper. I’d suggest contacting to resolve the issue - they should be able to provide some suggestions, and/or a replacement or refund if relevant :slight_smile:

It may be worth checking the Technical Details and Guides sections to make sure attempted operation has been within the gripper’s specifications, but given the previous one was working that’s likely fine. When contacting support about a faulty product it’s best to provide an order number / purchase date, as well as what’s been tested so far / known likely causes for issues. The latter part of that should mostly be provided just by linking to this post :slight_smile: