Motors running then communication lost

Hi, I converted to the navigator board and initial bench testing was fine. But after about 15 mins in the water the vertical motors run flat out and then communication is lost. Then it re-boots.
Bench testing; stabilise mode the motors run slowly, if I put a yaw or sideways input comms is lost again. In depth mode comms are lost within a couple of seconds with the motors running flat out without input (even if I put my finger over the sensor).
All suggestions gratefully received!
BlueOS 4.1.1
QGC 4.2.8

Hi @Teggles -
That’s a weird one! Can you confirm the ROV operates normally initially, and we don’t have a joystick issue here?
Are you operating with a standard battery for power?
How long is your tether?
How have you connected power to the Navigator and Raspberry Pi (pictures?)
You’re able to tell the Pi has restarted, or is it a communications issue only?

Yes, strange indeed. I have changed the controller, 150m tether. I am away until Saturday when I can post pictures of the set up and some log files. I wonder if it could be the fathom X board?

Just tried another laptop, same issue. here is a log of the events. If anyone could have a look I would be very grateful.

00000020.BIN (1.6 MB)

Hi Terry -
If you could provide some system logs from BlueOS, that would help us diagnose what’s going on. You can find those logs in the bottom left, by clicking the gear and then the Download button under System Log Files:



thanks for looking at this Anthony. here is todays file:

00000026 (1).BIN (652.5 KB)

This might be a better log to examine:

00000029.BIN (1 MB)

Interestingly, when using cockpit I have no control over camera tilt or the gripper, but in QGC all works as normal. One thing is consistent; I get very frequent lost comms when in water compared to when I am out of the water. I have examined the tether very closely - no issues I can see.
manual mode I have control until a large control input, then comms lost. Stabilise mode motors start to run slowly, and again a control input comms lost. Depth hold, the vertical motors go to full down and within a second comms lost. This is really baffling me, for about 30 mins after changing to the navigator board all was well, now I am losing work and my mind!

Hi @Teggles
Sorry fo the problems! Can you confirm you are running the latest stable version of
BlueOS, 1.1.1? You listed 4.1.1 but this is the Ardusub version - they are two different things.
Also, please provide BlueOS system logs (see my last post with instruction) in addition to the Ardusub log in order for us to assist. Thanks!

Can you also share how you are powering the vehicle? It sounds like your battery may be damaged, and the voltage is dropping very low when a heavy load is applied to it.

Interesting thought on the power, I have not checked the battery under load. I have a number of spares so will try them.
The logs attached are the BlueOS logs, downloaded just as you described.
Yes I am using Blue OS 1.1.1

Hi Terry -
Those logs are ardusub logs, not the logs of BlueOS itself. When those download, it will be named . You can find that menu in the bottom left corner, here is a better screenshot to orient you:

Hi Anthony, apologies - lets try this file: (3.5 MB)

Hi Anthony, have you managed to have a look at my latest log yet?


Hi Terry -
Sorry for the delay in response!
I don’ see anything weird in your logs.
Can you share information on how you are powering the ROV? What battery, and if you’ve modified the power connections in any ways?
Have you made any other modifications to the system? This was an R1 or R2 BlueROV that you’ve upgraded with a Navigator - are you still using a Raspberry Pi 3?
You may want to try upgrading BlueOS to v1.2beta2 (enable pirate mode for it to show up in list)

The symptoms you’ve described make me think you have a power or wiring issue, and not something specific to the Navigator. Pictures can be super helpful in troubleshooting remotely! Thanks!

Hi Anthony,

No problem.

The ROV is normally powered by an 18000mAh battery but sometimes I use a 10000mAH. I have used these many times before without issue. I have not modified the power supply in any way.
No other modes apart from my own frame and motors.
Upgrade to navigator with a raspberry Pi 4. ROV is standard - 6 thrusters.
I tried upgrading to 1.2 beta 2 and that made life much worse! Motors going all the time when armed.
I have changed the fathom X board in the ROV and now I only get “lost manual control” when using cockpit, with QGS it appears to be OK now.
Still have the vertical motors running when armed and in stabilise mode and then going flat out in depth mode in both QGS and cockpit.
Attached are some photos.

Hi @Teggles -
That’s wild!
I would guess that something is screwed up with your installation and/or parameters. I would recommend downloading BlueOS and flashing your SD card, and setting up the vehicle from scratch. You could alternatively just reset and load the default parameters. Either way, this does mean you’ll have to calibrate sensors and set motor directions again, but if the problems persist after this complete reset we’ll know to suspect the hardware - likely the Navigator itself!
I do notice in your second picture, that the heat shrink on the power sensor/supply looks pretty dirty, could it be corroded and affecting your power and or measurements?

Hi Anthony,

I have reflashed thé sad card, reset default parameters, calibrated etc. Changed a couple of cables. The heat sink is new but I will look at it again.
Looks like I will need to go back to the dealer and ask fo a change of board.

Thanks for the help, really appreciate it.

Kind regards,


1 Like

Well, I have changed the navigator board, changed few vertical parameters but still when depth hold is selected the vertical motors run to full speed. I have reflashed sub 4.1.1 and gone back to 4.1.0. No change. I have replaced just about all the hardware, updated/rolled back software, and I still have the issue.
Any suggestions welcomed.
On up side, I am not losing comms when depth mode selected.

Hi @Teggles -

You may want to verify this setting:

You may also need to calibrate your joystick:

Did you update to a newer version of BlueOS than 1.1.1? Maybe 1.2 beta 6?

Hi Anthony,

Verified the settings.

I am using QGC v4.2.8

On thé joystick advanced page, I do not have “allow negative thrust”
If I select full down stick is zero throttle, the throttle does not return to centre when I stop moving the stick. I need to select centre stick for the throttle setting to return to zero. Enabling deadbands works on all sticks apart from throttle when depth hold mode is selected.

RC mode 1,2,3,4 works as advertised but I still have the depth mode issue.

Safety, only board voltage and battery are enabled only.

Selecting depth mode in QGC or on the hand controller makes no difference. The order of arming then selecting a mode makes no difference.

I am starting to run out of ideas :weary:

I appreciate the help,