Integrating VectorNAV 300 into blueboat

Hey Team,

I’m trying to integrate a VN-300T into my blueboat. I have set the following parameters:

• EAHRS_TYPE = 1 (VectorNav)
• GPS_TYPE = 21 (ExternalAHRS)
• GPS_TYPE2 = 21 (ExternalAHRS)
• Serial3_Protocol = 36 (AHRS)
• Serial3_Baud = 115
• AHRS_EKF_TYPE = 11 (External AHRS)

I cannot get the blueboat to see the VN-300, I have tried swapping tx/rx.
any suggestions?

Hi @CA_BlueBoat -
Can you verify that Serial3Baud is set to 115200?
If you could share autopilot and BlueOS logs, that would be helpful in troubleshooting your setup. You can download the BlueOS logs from the gear in the lower left of the web interface, and the Autopilot .bin logs from the Autopilot Logs page on the left menu as well.

Hi Tony,

Thanks for the reply. Yes, Serial3Baud was set to 115200 for the VN-300 in the VectorNav software. I have attached the BlueOS logs. There are no recent autopilot .bin files available from once I started testing the VN-300.

The VN-300 has 2x serial ports, 1 is rs232, and port 2 is TTL which I have connected to the navigator board. I bought a TTL to USB cable which should arrive soon so I can test that data is actually streaming from that port.

Thanks for the help,
Cheers (18.2 MB)

Sure thing! Do you have the .bin log file from the autopilot also available?
Can you confirm what NMEA messages you’ve configured the device to send? Maybe you haven’t done that yet without the USB cable?

Hey Tony,

This is an older .bin file but here it is:

00000034.BIN (424 KB)

Thanks for the help!

Hi @CA_BlueBoat -
Does this older log file correspond to a time when you had the parameters setup and your VN-300T connected?

It is an older log file before I started playing with VN-300T.
How can I generate a new .bin file?

Or I could send over my .params file?

Hi @CA_BlueBoat -
Your parameters are already contained in the BlueOS log file.
To generate a .bin file, you need to power up the vehicle and arm it. The GPS should be connected during this period. Give it a few minutes and then disarm, and you should have a .bin file appear in the Log Browser menu.

Hi Tony,

Here is a .bin file from a few days ago, I believe it has the settings I was using trying to integrate the VN-300.
00000035.BIN (318.3 KB)


I just found a comment in the vectornav ardupilot library:

on line 44 it shows the settings for the VN-300. I wrote that using the vectornav software, re-flashed a fresh blueos install onto the boat, updated to the latest ardurover, wrote all the settings in the VN-300 installation guide (here: External AHRS Systems — Plane documentation), and it still won’t show up.

any ideas?


Any update on this?


Hi @CA_BlueBoat -
We reviewed the logs and nothing looks incorrect. If you reach out via our support form we’d be happy to coordinate a troubleshooting call with a member of our software team to investigate. Thanks!

Thanks for investigating this Tony.

One last question - Is there a way to view/monitor the data on the serial ports of the navigator easily? Just so I can confirm its streaming in properly.
Also, on your navigator board serial devices page (Connecting Your Device with Navigator and BlueOS) it says to use 2.2kohm resistors in series. Is this necessary? The VN300 is 3.3V.


Hi @CA_BlueBoat -
We can review how to check in on the serial data coming from the device in a support call! There are several ways to approach this - I prefer to use screen, which must be installed after taking the red pill. The serial port also needs to be removed from the autopilot’s access before opening manually to check if data is coming through.
The resistors are only necessary when connecting a Raspberry Pi directly to another Pi device, to limit the current driven. I wouldn’t expect them to be required in your setup. Is there any chance you’ve reversed the TX/RX lines?