Home        Store        Learn        Blog

How to see video in qgroundcontrol using raspberry pi and pikhawk

When I enter in 9000 a question mark is there “?”. I try to save but it cuts back to where i entered 9000 over the 5600. Looks like it won’t let me. I think i will change the 9000 to 5600. I think I read that is what it should be anyway. Here, look:
Note: default port for video in QGC application is 5600 but this is under this,
https://docs.emlid.com/navio2/common/dev/video-streaming/

This is probably a bid deal. I just went to change the
Set your GCS IP
- sudo nano /etc/default/arducopter
and my settings had :14550 for the port. So I’m going to leave it at that and try changing the port to that in QGS. See what happens.

There are two ports used by QGC, one for the telemetry connection (compass heading, voltage, etc) to the autopilot, and another one for video stream.

QGC looks for the telemetry on port 14550, and the video on port 5600 (or whatever you put in the settings).

Right. Okay.

Connection is ok. I get the OSD reacting to what I do with the Flight Controller. That looks alright.

I made that change you said to do. When I go to Q. / General. Comm Link, do I have to use?

When I go to Q. / General. Comm Link, do I have to use?

No.

I’ve downloaded the QStreamer files for Windows. Installed those. I’m using
pi@navio: ~ raspivid -n -w 1280 -h 720 -b 1000000 -fps 15 -t 0 -o - | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay config-interval=10 pt=96 ! udpsink host=<remote_ip> port=9000

Hit Enter

Setting pipeline to PLAYING…
New clock: GstSystemClock.

Still no image!

Maybe I’m not using the right version of GStreamer for windows. :confounded:

pi@navio: ~ raspivid -n -w 1280 -h 720 -b 1000000 -fps 15 -t 0 -o - | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay config-interval=10 pt=96 ! udpsink host=<remote_ip> port=9000

You don’t need to install gstreamer, you only need QGC.

I think GStreamer installed QGC. This time around I installed two lots of files.

Windows

Download the gstreamer framework from here: http://gstreamer.freedesktop.org/data/pkg/windows. Supported version is 1.5.2. QGC may work with newer version, but it is untested.

You need two packages:

gstreamer-1.0-devel-x86-1.5.2.msi
gstreamer-1.0-x86-1.5.2.msi

So what do you think i need to do to get this working?

Emlid just released some more photos of The Edge. I knew I shouldn’t have purchased this Flight Controller!!! :confounded: It being released next month. :weary:

This is what I think you need to do to get it working: How to see video in qgroundcontrol using raspberry pi and pikhawk

hi I have a problem when I want to start the Raspi camera

image

Well, have you tried checking the camera cable? Do you have another camera and cable you could try?

Hi,

Are you using a raspberry camera module or a usb camera ?