Hide "No GPS Lock for Vehicle" message

I recently built the latest Daily version of QGC and have been getting a “No GPS Lock for Vehicle” message displayed in the middle of the screen. I’ve looked around here and on a few other related forums, but the only questions about this seem to be by people who actually have a GPS unit and are having trouble getting it to connect.

Is there some way to hide this message? From what I’m aware most ROVs don’t have GPS units and it’s a distraction while operating.

I’ve tried commenting out the nmearx and wldriver screen lines in .companion.rc of the companion computer, but this had no effect. I’m expecting that since there actually isn’t a GPS this will stay as long as the pixhawk/companion computer doesn’t start seeing a GPS, in which case it probably has to be hidden from QGC. Happy to modify and re-build QGC to remove the warning temporarily, but I sort of feel like this should have a disable/hide option in the QGC settings, and am wondering if it’s there and I just haven’t found it, or if there’s some other simple way to turn it off.

I am also have a similar issue, looking for how to remove No GPS Lock for Vehicle overlay

This is a bug. I filed an issue. I’d consider sticking to 4.0.11 for now.

1 Like

and further. battery parameters and some others are not saved after reboot. voltage and current consumption, they go into depth

This was also fixed and will be available in the next stable release.
Check Telemetry widget: battery items show depth instead · Issue #9462 · mavlink/qgroundcontrol · GitHub

1 Like

Greetings All, has this been fixed, or should I downgrade QGCS to version 4.0.11? Thanks!

Hi Ian,

The parameter saving issue has been fixed in Stable_V4.1 now, but the “No GPS Lock for Vehicle” message is only fixed in master, not any of the Stable releases/branches. If you’re already building the code yourself and want to use a stable branch, you can apply the relevant changes by yourself (it’s only a few minor modifications) :slight_smile:

If you’re not building QGC then it’s recommended to use the download link from the software setup guide, which is currently still on 4.0.5.

Hi Eliot,

Don’t understand your advice on how to remove the “No GPS Lock” from screen. I am running 4.1.2 atm. Do I need to roll back?

Hi @josef,

If you’re not already building QGC from source yourself, and want to just download a QGC version that doesn’t have the message then I’d suggest you use the download link from the software setup guide I linked to in my previous comment.

If you are building QGC from source and want to remove the message, you can either

  1. go back to a previous version (4.0.5 definitely doesn’t have it, I believe all of 4.1.x does have the message at this stage, so possibly just checkout Stable_V4.0), or
  2. checkout master and build from there (may introduce other bugs and untested development features, but will at least remove the message), or
  3. checkout Stable_V4.1, then follow the “relevant changes” link I provided and change your copy of the three files specified in that commit (remove any red bits and add the green bits at the lines it tells you), then rebuild QGC and the message should be gone

:slight_smile:

Thanks Eliot, will try that.

Best

1 Like

@josef,
Thanks to @williangalvani for bringing this up in the QGC dev call last week, this is now merged into the Stable_V4.1 branch. It’s not yet available in a specific 4.1.X release, but if you’re building from source then you should be able to checkout Stable_V4.1 and build and it shouldn’t be a problem anymore :slight_smile:

1 Like

Same issue here… Video is just freezing / grey’ish on QGC 4.0.5, installed QGC 4.1.3. Video all good but the "“No GPS Lock for Vehicle” notice. Rolled back to QGC 4.0.5 video is poor. We are experiencing this on two vehicles now.
Any tips or timeframe for any further updates?

From what I understand this issue is primarily due to the surface computer using some or full software decoding of the video frames, so is an issue with the computer specs/QGC implementation. Every vehicle that sends camera data above a certain rate will have this issue if the computer at the top is using software decoding and doesn’t have the specs to do so fast enough. Our video troubleshooting steps include a few suggestions re power supplies and computer settings that can potentially get the computer to use hardware decoding instead, but it’s indirect. The QGC update just provides forcing hardware decoding as an explicit option.

As mentioned above it’s possible to build the latest stable code if you’re up to it, which will remove the message. I don’t believe QGC has a set release schedule, but the last four have been about 2 months apart, so if we’re lucky there’ll be one in July. I’ve asked our software team in case they have any extra details (I’ll get back to you if they do know something), but QGC is a project we contribute to but don’t own, so we’re not in control of when releases happen.

Just FYI to those of you watching this thread, QGC v4.1.4 (which fixes this issue and some others) was released a couple of weeks ago, and is now available to download from the official releases :slight_smile:

Hi.
Have installed 4.1.4 but still have the samme problem. Do this have something to do with the versions on the pixhawk?

Hi @rune,

I don’t believe it should, but if you’re not already on the latest stable ArduSub version (4.0.3) then it likely wouldn’t hurt to update.

Note that if your Pixhawk has a GPS connected but it doesn’t have a position lock then the message will (and should) still appear - this fix is just for hiding the message for vehicles that don’t have a GPS connected at all :slight_smile:

Following up on this,