Fixing IP address problem

My problem is that i wanted to change my BluRov2 IP from to and i tried to do that by deleting the GCS Client Link and adding a new one with a different IP but after that i got this error.

I tried to fix that changing the ethernet configuration and changing the ip too but after that i couldn’t enter blueos using or

I tried to revert everything by putting the original GCS Client Link and the original IP,but after that i can’t connect to QGroundControl and the mavlink vitals from BlueOS doesn’t work anymore. What should i do ?

Hi @SRA_Rob, welcome to the forum :slight_smile: is not an IP we use, so I imagine you’ve either misremembered it or made a typo. By default the vehicle is assigned the IP address, and for convenience of components connecting automatically we recommend assigning the topside computer’s interface to the vehicle to use the IP address

If you’re planning to change the subnet being used for ethernet communications I’d recommend first connecting the vehicle to a local wireless network. so it’s at least possible to connect via http://blueos-wifi.local if something goes wrong with the IP assignment / connection. Note that the “GCS Client Link” MAVLink endpoint (and the video streams) should be targeted at the topside computer’s IP address, and both the vehicle’s and topside computer’s IP addresses need to be in the same subnet (e.g. both set to 192.168.2.x, or both set to 192.168.3.x) to be able to reach each other.

Make sure the topside and vehicle IPs are in the same subnet, and that the GCS client link is set to the topside’s IP.

Yeah,the was a typo ,but i only had this typo in that post.

I realized that when i did the gcs client link i didn’t change the type of endpoint and it was a UDP Server instead of a UDP Client, also i’m using for the client ip now . I fixed that and i didn’t have errors in the BlueOS but i still can’t connect properly to QGroundControl and only work the camera . The Server Link IP is but the documentation of this software says that also works. And i’m afraid of changing that ip

EDIT: I fixed the camera by putting the new ip and now BlueRov2 works properly on QGroundControl. Now i need to change the server link


You only need one link to work, and the server is generally to the loopback IP anyway. For some context, the server link was added to try to make it easier to set up the vehicle without needing to make use of static IP addresses, but if you’re already using them (which most setups do, and is currently recommended) then the client link should be fine :slight_smile: