Home        Store        Learn        Blog

Firmware upgrade of pixhawk1

Hey! i tried to upgrade the firmware of pixhaw1 by using QGroundControl.

Also i tried the firmware update by using the waf tool of ardupilot. Neither methods are not working. Any suggestions what is going wrong with pixhawk1?

Hi,
That method is for upgrading via USB. At that screen, you shuold disconnect and reconnect the Pixhawk from your usb port so it is detected.

For upgrading with the Pixhawk in the ROV, via Companion, check the instructions here.

Hey! I tried both methods. The result from the Companion is:

The Companion version is 0.0.25.

Hi!

Try uninstalling the modemmanager in Ubuntu. Check the QGroundControl docs here.

Hey! I have uninstalled the modemmanager. Now i’m trying with ST-link but without success.

Have you tried doing it through QGC after uninstalling the modemmanager?

Hey! Yes i’ve tried after the uninstalling the modemmanager. Also before i used a newer version of pixhawk 2.4.7 (the previous one was 2.4.6) i tried to flash the ardupilot 4.0.2 with methods:

The new pixhawk 2.4.7 is flashed from companion PC without problem.