Failsafe with loss of joystick

Greetings all, the new blue boat looks fantastic, we do lots of hydrography work with surface vessels and one big problem we have on some bodies of water is thick weedy vegetation growth. I’m excited to see how the blue boat performs in these conditions, so we have a pre-order submitted.

I do have a question regarding RC and Radio failsafes for the Blueboat. We currently have 3 USV’s for hydrogaphy work and employ a suite of connections to the boat. We use a 900 MHz for telemetry only to a companion comptuer/ground station, 2.4 GHz HereLink for RC control and telemetry, and a 5.8 GHz network bridge to RDP to onboard computers running Hypack and viewing IP PTZ cameras.

Please note we due use the latest version of Ardurover as rover firmware, pixhawk orange as autopilot, and Mission planner for survey setup and telemetry viewing…

Sometimes the 5.8 GHz dropps out due to range (>1.1km), but the onboard computer will continue to collect the data, and we can always bring the boat back with the 900 or 2.4 systems if there is a problem.

I have tested using a single 2.4 GHz connection (microhard radios) on some of our test terrestrial rovers for telemetry and using a gamepad joystick for RC control. What I have experience is if the joystick is disconnected, the PWM values for servo 1 (steering) and servo 3 (throttle) drop immediately to 900, and the vehicles start spinning in circles as the steering defaults to the 900 value. Once the joystick is reconnected and enabled the PWM values go back to 1500 and the rover stops spinning. I see the Blueboat only has a single 2.4 GHz telemetry connection and it is advised to use a joystick for remote control. Have you experienced a similar issue with the Blueboat if the joystick is disconnected? I see the Blueboat uses the Blue OS and a Navigator autopilot, does this hardware/OS/Firmware solve this problem? Thanks for your time.

Hi @FairweatherIT,

BlueBoat runs ArduRover in a skid steering configuration, so it uses ThrottleLeft and ThrottleRight servo outputs rather than separate steering and throttle outputs. It’s possible that avoids the spinning behaviour you’ve described, but I’m not certain. If that’s an inherent problem when ArduRover is used with RC instead of autonomously then BlueBoat will also have it, but I imagine that’s configurable to some degree via the firmware parameters, and if it’s just a bug it should be fixable.

I’d recommend asking about how to solve the issue with your current setup in the boat section of the ArduPilot forum (assuming searching the docs and forum hasn’t yielded anything), and if it’s not already straightforward we may be able to contribute to ArduRover to improve how that situation is handled if it’s also relevant to BlueBoat.

Thanks Elliot! Yes I have perused the arudpilot discourse seeking the same questions, but I have not addressed it there. Most of the posts are in arducopter regarding joysticks, and they all also use a secondary RC controller (Taranis, Futaba), so if the joystick is disconnected it reverts to the RC controller PWM signal…otherwise a crash. A couple users were contemplating programming an Arduino to output PWM signals at 1500 to keep the craft somewhat in a loiter mode as opposed to having all signals drop to 900, but no further posts if it worked. I’ll keep investigating and update any results here…

Hi Guys!
When operating my blue boat, via 4G cellular connection, I disabled a parameter related to the failsafe action. This means that if connection is lost, no mode change happens - auto missions continue, or loiter, or manual… This can lead to problems, but less likely with cell connection? If I’m in range of the boat, I can connect to it via WiFi as well, but with the antennas on the modem/router I’m using internal the range is only ~100m at best.

Configured the unit to use ipv6 for default, and installed zerotier on BlueOS instance running on vehicle Pi4. Configured a mavlink connection to point at my control computer’s zerotier network IP addresses, and was off to the races! It handles changing of connection mediums amazingly well, so jumping between different connection types results in <1-2 minutes of no connectivity. I hardwired the pi to the router and disabled the pi wifi radio to save a touch of power.

Ping viewer also works over the connection, with the viewer even finding the UDP source @ zerotier address for vehicle.

1 Like