Dual Omniscan 450 implementation

I’m unable to get dual Omniscan 450 (hereafter O450) units to work together (in a side scan configuration). The O450/BlueBoat integration page appears outdated at present (as of 12/20/23, e.g. the newest firmware release for the O450 now changes IP addresses via MAC address rather than a broadcast message, negating the unplugging ethernet steps) so I’m wondering what else is new?

I can get two units to work together using the instructions here: https://docs.ceruleansonar.com/c/v/sonarview/device-specific-controls/omniscan-450/setup-instructions-for-multiple-omniscans
but only via the standalone SonarView app. I have added a config.json into /usr/blueos/userdata/SonarView but still have no luck with establishing a dual setup within the SonarView app in BlueOS. And, probably related, I can’t find where the sonar files are saving to. Editing the “SonarLink and Discovery Options” within the Settings console in the BlueOS/SonarView app seems to have no effect (using either a relative or absolute path).

Anyone have an update on how to get this going?

Yes we did overhaul the approach to configuring mulitple Omniscans with the latest SonarView release. Nick will respond here on your specific issue with the BlueOS hosting. Sorry we dropped the ball communicating the changes to The Reef team and the new SonarView release was almost simultaneous with the launch on the Reef.

1 Like

The BlueOS version of SonarView should default to a logging path of /userdata . This is an absolute path inside the docker container which maps to /usr/blueos/userdata/ in the Raspberry Pi’s host OS. Your config.json file is in the correct location, as long as your logging path is set to userdata.

EDIT: @nidzieko It looks like the most recent build of SonarView for BlueOS didn’t get the proper default logging directory set, my bad. Fixing it and pushing a new version now. You can manually set your SonarLink log directory to /userdata in SonarView’s App Settings page, then reload the browser window. Your config.json should take effect after that.