Home        Store        Docs        Blog

Connection between raspi and pc

Hello,

I recently started working on a BlueRov2. I’m trying to make a security measure if the ROV lost the communication with the operator (QGC) in case of cable break for any reason. The purpose of the safety measure is to bring the ROV up to the surface. I have made a script with a raspberry pi who every 5 minutes test the ethernet connexion and if there is no connexion the script try to connecte every 5 seconds. After 4 minutes if the raspberry is still disconnected a function is launched (the security measure).

It was working perfectly fine with the raspberry but when i tried it on the BlueRov2 I’ve been dealing with a problem the script wasn’t working he showed that the ROV ethernet connexion was working although I disconnected it form my pc.

I have tried with the ip 192.168.2.2 and when i tried with the ip 192.168.2.1 I find out the raspi wasn’t able to communicate with my computer throught the cable. When i tried to ping the ip 192.168.2.1 with the raspberry it wasn’t working but with my pc i could ping both ip 192.168.2.2 and 192.168.2.1.

I think the Phantom-X prevent the raspberry to communicate with the pc and I don’t know how to resolve this, some of you have faced this problem?

Sorry for my poor english.

Clément

@pclement28 There is already a failsafe built into ArduSub, it is known as “GCS Heartbeat”: http://www.ardusub.com/operators-manual/failsafes.html You can set it to just disarm the vehicle so it doesn’t continue on its last input command or to surface if you would like.

Hello @kklemens thank for your answer, I didn’t saw this option. I’ll continue my security mesure anyway because I want something more custom ( blinking light + bring up the ROV to the surface).

I have found the key off my problem, I had to create an exeption in my fire-wall to allow ipcm4. Now the program is working perfectly manually. I just need to find how to set up crontab in the BlueROV2.