Connecting BlueROV to Micron mk3 Sonar

I am currently working on integrating a tritech MK3 Sonar to a Blue ROV standard for a client. (6 thruster).
I have the new blue navigator flight stack, going up the blue slim tether (1 twisted pair 2 lines) going through an FXTI box… The tether is connected to a potted penetrator. On the old flight controller with the pixhawk the integration for this was rather simple, we would direct the data using a UDP port and then send it to a serial connection on the topside of the computer. Using the new BLUE OS is not the same, I can still send the data from 485 through the pi and up but its not received on the top end due to it destroying the bridging… It goes through a different protocol on the topside surface. To Suffice this I downloaded a free virtual com port software to try and turn that UDP data into serial so it can be registered by the genesis sonar software. With no luck, I have programmed the Genesis to be read as serial on the topside with 9600 baud, I tried to raise the bod rate so it does not lull the sonar, this was unfruitful. I know that if I bought a larger tether I could just tie the sonar to the other twisted pair and send it up the line but I currently don’t have that option. IS it possible to send the sonar data congruent with the ROV data? or do I have to purchase a new tether in order to send this data.

I am running out of options and was wondering if anyone has had an issue, and if they solved it… I found a few things throughout the other forums but it was old information for the pixhawk flight stack and not the Navigator flight stack. I also found that Rusty was able to do this with a dual twisted pair, is that a necessity? or can it be sent on the same line?

Any tips that I can try will help! thank you very much.


Hi @DaltonHybrid, welcome to the forum :slight_smile:

We’re not entirely clear here on what it is that isn’t working. The Bridges service in BlueOS (requires Pirate Mode to see) should be able to forward serial data over UDP, which should be equivalent to the functionalities available on Companion’s Routing page - is that not working for you? If so we’ll need to investigate and fix it.

Assuming Bridges does have some bug or issue, you can potentially try installing @williangalvani’s VirtualHere extension via the BlueOS Terminal page, then install a VirtualHere client on your topside computer, which allows presenting a USB device that’s physically connected to the Raspberry Pi as a USB device connected to your topside computer, which may then be detectable by your sonar software. Be aware that our extensions architecture is not stable yet, so working with any extensions is currently only available via terminal commands, and will have limited support.

If it’s going via the Raspberry Pi then it should be sendable through the same tether pair as the rest of the ROV communications (although there may be bandwidth / performance limitations when doing so). If you want to send an RS-485 signal directly to the surface then that will need to be on a separate pair, to avoid conflicting with the ROV communications, which use a different protocol.

1 Like

Yes, I was using a UDP Sever to forward the data and then send that data up the line, its not working and my clients computer wont see it. I will try the VirtualHere Extension on companion and surface computer and let you know how it goes. Worst comes to worst we will purchase a dual twisted pair tether and go from there.
Thank you for you input.

Best of luck getting over this issue, but when you get a chance I would love to hear why you selected the Tritech Mk3 vs the Ping360 and what it costs. Cheers, Larry.

Serial over UDP always requires some kind of UDP-to-serial conversion software on the receiving computer. Have you confirmed that the sonar signal correctly gets transferred to the topside by the bridging functionalities of Companion on a Raspberry Pi 3B, and that your receiving UDP-to-serial software allows it to connect properly to Tritech’s control software?

If so, BlueOS’s Bridges service should be able to do the same forwarding as Companion, and it’s important for us to know whether that works as expected. If that’s not working, please let us know which BlueOS version(s) you tried on, and what settings you specified for the bridge.

Note that there have been some improvements to Bridges since the 1.0.1 stable release, so if you haven’t already please try the latest beta (1.1.0-beta.9) release in case that helps :slight_smile:

Alrighty then, hopefully it works out :slight_smile:

I appreciate your help getting this going. This morning I had tried to do what you had said by going to the terminal and downloading virtualhere, It worked on the top side computer however the companion computer can not find a host (it is connected to wifi so it does have access to servers). This was the message I received below. I am sorry for the quality of image, we are doing this for a municipality and their laptop is locked from connecting to certain wifi’s so I cant post from that computer…

Following trying to repeat that for a few times in the terminal, I then decided to change to the 1.1.0-beta like you had said…, I like the direction it is going the end points not breaking when the system is restarted is nice. However, I still can’t convert that data at the surface. Here are my bridging settings as well as my end point settings

I am using a program on the topside computer called “netburner” it takes UDP or TCP and converts them over to a virtual comport that can be detected by sonar software, the sonar software I am using is ‘Genesis’. I will attach my settings below. I know that the program is working correctly because it creates a virtual com port in my device manager and I can select it in my sonar software… could it possibly be because I have the incorrect ip and port settings? I have tried to change them but the BlueOS terminal just closes and says it can not be created.
Again, with the pixhawk flight stack this was rather easy we could just direct the data straight up the line with no virtual com port, and I am not sure what changed from there but I understand development takes time so I am willing to provide you with what ever troubleshooting details I can! If I missed more information that you need to know please tell me and I will get it to you ASAP!

and here is the settings for the Mk3 in genesis— I can get these settings because I connected the sonar directly to the computer bypassing the tether lines, so I can conclude from that that it is not a hardware issue on the sonar

Blue forums only allow me to post 1 image per reply so I will reply with all the following images in a string off this comment. My apologies for the inconvenience



Here are the virtual comport settings

Sonar settings

The Mk3 was the sonar that was given to us by the client they had it on another ROV that they replaced for the Blue view… I am unaware on the price, but I believe its in the $7-12kUSD range(dont quote me on that because Its a guess). Tritech varies the quoted price depending on what you order with it and what options you chose to add to the sonar. you have to talk to the company directly, which I have never done.
We have gone with the mk3 and we have also used the ping 360 on multiple blue ROV’s that we have built. Both are spectacular little sonars, that being said its more about the software that accompanies them. The ping 360 is a really great inexpensive option to get a scanning sonar on your ROV and using it in the field is streamline, reliable, and has clear image quality.
I have nothing bad to say about either sonar, nor do I have a preference on the use of one or the other! Its more what about what our clients are familiar with or what they would like on their vehicle/ the job that they are performing. We also have some clients that use both interchangeably! So really the only deal maker is the price of the sonar and what is in the clients budget.

Hope that helps! Cheers!

About virtual here, it was my fault! I think I removed the “latest” tag as I’m working on the extension management system.

Try williangalvani/blueos-extension-virtualhere:v1.0.0 instead

edit: changed the tag to v1.0.0

Thank you so much for the update! I will retry again with that new command line!

Thanks for that. Much appreciated.

I have an update for you Eliot…
The virtualhere software worked incredibly well and there was no degradation in performance of the sonar, worked on 115200 baud and was seamless. We are going for water testing tomorrow, so we will know more but our bench tests looked and worked better than expected.
We will also be using virtual here in the future!

Thank you for the help, it saved us in a pinch!
Take care!

1 Like