Home        Store        Docs        Blog

Companion update not working

Great job guys. Looking good.

I do have a question: As I was running the latest beta versions, the companion version at the moment is 0.0.19. When on the “System” page, it indicates no new version to update. I have downloaded the latest stable version 0.0.20 to my laptop (there was two, a .gz, and a .zip). What file format is the System page update looking for? The .gz file?

Thanks

Hi @k-deboer, make sure you have an internet connection on the network page, and try refreshing the system page and waiting a minute for it to check for an available update so the button appears.

We have not prepared the file for the offline ‘upload update’ option you see in companion. You can download the latest image here, and you will need to re-image the sd card in the raspberry pi with Etcher. I’m not sure where you found a .gz file.

I have the same issue. I am stuck with Companion 0.18.

Internet connection is working because I have flashed Ardusub (which is no longer recognized)

I dont know if it helps You, but I had to use wired ethernet:
https://discuss.bluerobotics.com/t/software-updates-april-2020/7234/22
Bo

1 Like

Yeah I tried that.

Hi @etienne,

Try resetting the mavproxy settings to recover access to the autopilot.

How long before you prepare this file? It seems a lot of people will experience this issue.

No change

Hi
When on the “System” page, it indicates no new version to update compagnon.
I have Wifi connection
I’ve been waiting since you announced the updates but still the same problem …

OK, i flash sd card, and now update compagnon is here !!