Home        Store        Learn        Blog

Problems with Update Companion Software

Hi,

I am trying to update Companion Software on my Raspberry Pi 4 to the latest version (0.0.26).

When i opened web-interface my Version was 0.0.1, so i clicked on Update button and then i am asked to confirm replacing. (1 screen)

But i can’t confirm it in any way, i pressed buttons on my keyboard, nothing works, also i tried to write in rasbperry’s terminal via ssh, nothing works. After few reconnects it somehow shows Version: 0.0.22, and sometimes it shows Version: 0.1.0 but i think it’s visual bug. (2 screen)

I tried to upload zipped image of 0.0.26 version, and i got “validating archive
Archive does not look like a companion update” (3 screen)

How can i confirm update in web-interface?
Are there any other ways to update companion software to the latest version?

Thank you

You can update the companion software by pulling the card from the pi and flashing it with Etcher, I think Rusty added a guide somewhere but I believe its for older versions of the machine. (pre 2017 I think) Updates usually fail due to bad internet connection, it should take around 10-20 mins, and refreshing the browser will show if it has worked

1 Like

Hi @Denis, welcome to the forum :slight_smile:

We currently only support the Raspberry Pi 3B, so don’t actually support Raspberry Pi 4 at this stage (although we’re aiming to soon together with a broader update of the companion software). There’s a github issue here about RPi3B+ and RPi4 support, and a pull request here for work on an installer script for getting the current companion version on RPi4. From what I recall the installer script works for the most part, although it has a couple of issues that are discussed in the PR thread (including some fixes in a PR down the bottom that I made last year while working for another company).

In case you bought your Raspberry Pi from us, in which case you actually have a Raspberry Pi 3B,

It’s possible you need to extract the .img file, although it’s also possible that manual uploading doesn’t work. The 0.0.26 update release notes mention that the update

  • Remove unsupported ‘upload companion update’ option from the webui

I’m not sure at which point it stopped being supported, so your current version might not be able to do it. The intent is very much to use the auto-update option based on detecting an available update where possible so it can just do any changes required to get you from your current version to the latest one.

As @murf mentioned, it’s also possible to directly flash companion onto the raspberry pi SD card, which there are instructions for in our installing companion guide in the ardusub docs.