BlueOS Bridges not working like Companion

<tangent discussion moved from original post to its own topic>

Bridges are currently the only thing stopping me from switching to BlueOS.

I’ve already tried 1.1.0-beta6 version yesterday. In comparison to the 1.0.1, now I can establish bridge between Arduino connected to USB but I still cannot read data from UDP. I’m using simple application wrote in Matlab. It works without any issues when using Companion (0.0.31) but when the bridge is established using BlueOS, Matlab states that the UDP is in use with other process :frowning:
Perhaps I am doing something wrong. Do I only need to create a bridge on the “Bridges” page to set up USB to UDP data routing? Should I still look somewhere else in BlueOS?

Below are the Routing settings on Companion, on which I manage to read data from the Arduino. On the BlueOS I’m trying to use the same values.


Not sure what’s going on there, so I’ve brought it up internally to try to get some clarity.

Given your topside application is saying the UDP port is in use, it would seem like there’s something else on your topside computer that’s connected to the same port, but if that’s the case I would expect it to also fail to connect when using the Companion software instead of BlueOS. Does it work to use a different port, and/or does it work after restarting your topside computer, or with a different computer?

Yes, as you wrote - if there was something blocking the UDP port on my computer then I wouldn’t be able to read data when I use Companion either. The problem only occurs when BR2 is running on BlueOS.

So I’ll try to do some trials on BlueOS with different address/port settings. I’ll let you know soon if it worked.

Ok, so after several attempts I still can’t manage to establish a working UDP.

I first tried the settings as I was using in Companion (when running on Companion these settings work with both Matlab and other UDP reading programs without any problems). It is not possible to create a bridge at all.

I then tried changing the IP address. With set, the bridge is created, but neither Matlab nor other programs read data from it (the Arduino sends a short string of data every second).

When setting the IP as I get the following error:

Furthermore, I noticed that with BlueOS 1.1.0-beta6 it takes much longer to connect to QGC and blueos-frontend than with Companion. There is also a loss of connection to BR2 every few minutes:

So I’m going back to using Companion because then everything worked fine and didn’t break the connection at all.

Hi @en_morty,

Thanks for reporting the issue, I was able to replicate it and we are going to work on a solution as soon as possible.
To follow the status: bug: Failing to create bridges when configuring as a client · Issue #1113 · bluerobotics/BlueOS-docker · GitHub

Now to help you using BlueOS:

On the first image you are configuring Companion to connect over a UDP Server running on the surface computer ( with an UDP Client, on the BlueOS you are configuring a UDP Server when using the local ROV IP ( /, for that to work, your matlab code will need to be a UDP Client.
That’s a temporary solution while we are fixing the issue, be sure to send something from the matlab code to register your UDP client.

Ok, thanks :slight_smile:


We closed the issue and created a beta release with the client feature.


In version 1.1.0-beta.8, the bridges work as in Companion. They also remain saved after restarting BR2. Matlab is now fully reading the data. Many thanks for your help! :smiley:


Hi @en_morty,

I’m glad to hear that, let us know if you find others problems with BlueOS.
We are also working heavy to release a new stable version this month.

1 Like

This topic was automatically closed after 10 days. New replies are no longer allowed.