Home        Store        Learn        Blog

Bar100 large surface pressure offset

Hi All
I have some weird readings for the surface depth in QGC : some times around -4 meters, some times around -9 meters.
So I tried to run the pressure sensor calibration and ended with that errors :
EKF2 IMU0 forced reset
EKF2 IMU1 forced reset
So I ran all sensors calibrations. Same problem occured and still the same surface depth weird readings.
So I upgraded Ardusub and ran again all calibrations, same problem…
This is the log :


I have to precise I’m using a BAR100 pressure sensor.
Have you got any idea on how to solve this issue?

Hi @Seb,

Resetting the kalman filters that estimate the vehicle’s motion/position state makes sense when you re-calibrate your depth sensor, otherwise they might register a significant acceleration that was actually caused by re-setting the depth zero-point. Note that it’s a warning not an error - the calibration was successful, so the EKFs are reset to start fresh with the new calibration values :slight_smile:

That’s definitely an unusually large offset and range, and if the pressure or measurement time wasn’t actually significantly different between those readings it would suggest to me that your Bar100 might be damaged/faulty.

Note that the Bar100 has a \pm500 mbar accuracy, so depth calculations based on it can conceivably be off by up to ~5m if it’s not calibrated. Its precision is 3mbar however, so it should be able to measurably detect ~3cm of depth difference in fresh water. When the depth calculation is calibrated to a given pressure (the barometer calibration you ran), the estimated depth from that point should be accurate to within the precision amount (subject to water density differences, which shouldn’t be particularly relevant for measurements at/near the surface).

I’d suggest you try putting the ROV in some water and watching the depth readings. If it’s just an offset issue (e.g. caused by different air pressure from the initial calibration location+time) then the calibration you did should solve that, and the readings should reasonably accurately reflect the depth the sensor is at (you can try pushing it down into the water a bit to see the variation).

If the measured depth is varying from what it should be after you’ve performed an offset calibration then there’s likely something wrong with the sensor, in which case I’d recommend you contact support@bluerobotics.com, and link them to this thread. They can help make sure if the sensor is damaged, and are the people to talk to about a potential replacement or refund :slight_smile:

Hi Eliot
Thanks for your answer. I’ll make these tests as soon as I can, at a few meters depth, and I hope that will solve the problem :face_with_raised_eyebrow: