12 Volt Input, 8.5 Volt Output?

During testing, we noticed that our ROV motors were spinning slowly. We checked the input, and we had about 12.5 volts. We then checked the output from the control system, and it was giving 8.5 volts. We are wondering why there is a limited output (would it be the Saberteeth, PixHawk, or QGround control?) and possible ways to fix it. We would like to use this control system, but if we can’t get a higher output to our motors we will need to come up with a plan B since we intend to compete at a MATE competition.

#Here is some information about our control system

Above is a photo of our control system, but our Sabertooth DIP switches are currently set for RC input (unlike what is shown in this photo). The Saberteeth are 2x5 from Dimension Engineering-more info here. In QGroundControl, we are using the ROV with side-by-side vertical thrusters configuration. We have six motors (12 wires) that are currently wired into the Saberteeth (unlike what is shown in the photo). The motors are bilge pumps with propellers attached and the wire is Ethernet. We have the Fathom-S Tether Interface boards, but we currently do not have a camera set up.

If you have any other questions, please let me know. We would like to figure out how to solve this issue soon, and we have already done some troubleshooting.
Thank you,
Emma Hagen
CEO and CFO of Altum Operations

At which point are you measuring 8.5 volts? If it is at the output of the sabertooth speed controllers, I suspect that this is the duty cycle @ 12V that you are observing, and perhaps you need to increase the output pwm range (default is 1100-1900 microseconds) to reach the expected endpoint of the sabertooth speed controllers.



What current are you drawing and through what length and gauge of tether? If you are in fact driving the Sabertooth controller at full throttle, you may be losing electrical power due to the voltage drop through you tether if you are using an an insufficiently thick tether for your current and length.



I just realized something else- if you are using ArduSub, then the thruster gain will be set to 50% by default- to get full throttle you will need to bump up the gain to 100% by pressing the button you have mapped to that function.


1 Like

Would I adjust the gain under Parameters or somewhere else?


Never mind, I found your explanation here in an old forum topic. Thanks, it seems to be working great now! We will test it in the water to see if the issue is solved.

1 Like

The gain scales the pilot input by a certain percentage. You can configure buttons on the joystick to increase/decrease the gain in 25% steps. The options are called ‘gain_inc’ and ‘gain_dec’. The default buttons for changing the gain are the up/down buttons on the D-pad.


Thank you very much for the help! The ROV is up and running!
Tobin Cox
Electronics and Software engineer of Altum Operations