Home        Store        Docs        Blog

The communicatory question between pixhawk and raspberry pi3

(DS Wang) #1

Hello! I’m DS Wang

I’m researching in this page
http://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html

I had already finished the part of “Setup th RPi” and “Setting up the Pixhawk”
And the network had been finished, too.

I built a linux system on vmware.
And I used PuTTy to connect the RPi by SSH on linux system above.
The required packages had been downloaded and installed already.

But…I have a question now.
When I used this command
“mavproxy.py --master=/dev/ttyAMA0 --baudrate 57600 --aircraft MyCopter”
It showed these information like the picture

Does anyone know how to solve it?
I appreciate your help!

DS

0 Likes

(Jacob) #2

How is the Pixhawk connected to the Raspberry Pi? USB? If you are using USB, you should use /dev/ttyACM0 for ‘master’, if you are using the RX/TX pins on the Raspberry Pi, make sure you have disabled the console login on the serial interface.

-Jacob

0 Likes

(DS Wang) #3

Hello! Jacob!

I connected the RPi and the pixhawk by using the RX/TX pins.
If I disable the console login on serial interface, the “enable_uart” will be set 0.
But this note show I need to set it 1

How can I do?

Thank you!

DS

0 Likes

(DS Wang) #4

Does anyone know the solutions of this problem…?
Appreciate for your help!!!

0 Likes

(Jacob) #5

You need to do two separate things:

  1. Enable the serial interface with ‘set enable_uart=1’
  2. Disable console output on the serial interface, there are instructions to do this here.

-Jacob

0 Likes

Does ardusub-3.4 support telem1/2 communication with pixhawk?
(DS Wang) #6

Genius!!!
I solved this terrible problem !!!
They connected with each other, and they can give command to the other one!!!
I can control pixhawk by RPi3 !!

Jacob! I really appreciate for your help and comments!!!
Thank you very very much !!!

0 Likes

(Jacob) #7

Well done, DS. I hope you can have fun with it now instead of worrying about how to get it to work!

-Jacob

0 Likes

(DS Wang) #8

I promise you I will enjoy it!!!

Thank you! Jacob!
Cheers!

0 Likes

(Arpit Srivastava) #9

But how i will configure pixhawk. If i want autonomous?. How to calibrate it?

0 Likes

(Jacob) #10

Hi Arpit, try reading more about ardupilot and ardusub. Let us know the status of your project and what your specific problem or question is.

0 Likes

(Jacob) split this topic #11

3 posts were merged into an existing topic: Waiting for heartbeat from /dev/ttyAMA0 msg when connecting rsp and pixhawk

0 Likes

(Devang Shetty) #12

Guys please help me resolve this issue, I have ssh(ed) into my pi and downloaded and installed all the libraries, my Pixhawk in connected over USB but I’m getting this error please help me resolve it.
I am following the standard Dev docs to make the connection between the Pi and the pixhawk

0 Likes

(Jacob) #13

Try using python2

1 Like

(Devang Shetty) #15

Yes! That was the problem. But my mode is still not changing to STABILIZED.

0 Likes

(Patrick José Pereira) #16

Hi,

Before changing to stabilized mode ArduSub will test all failsafe mechanism, do you have a properly properly assembled vehicle ?

0 Likes

(Jacob) #17

@patrickelectric There is no prerequesite for switching to stabilize mode. It should always work.

@DShetty will you please demonstrate the problem for us with some text copy/paste or screenshot?

0 Likes