Home        Store        Docs        Blog

Setpoint Velocity issues with bluerov_ros_playground

(A. Koh) #1

Hello I am trying to cause my BR2 to move from publishing geomerty_msgs/TwistStamped messages to the /[node]/setpoint_velocity/cmd_vel topic on both the /BlueRov2 and /mavros namespace when I run either bluerov2_node.launch or user_mav.launch.

I can successfully control movement by publishing to /BlueRov2/rc_channel[i]/set_pwm topics and through my gamepad controller on user_mav.launch.

On user_mav.launch it shows that /user_node is talking to /mavros through the /mavros/setpoint_velocity/cmd_vel topic but when I rostopic echo it there is no output. However, when I echo /mavros/local_position/pose I can see the coordinates change accordingly to my controller inputs.

Out in the pool, I could control the movement of the BR2 using the rc_channel topics but could not with the /BlueRov2/setpoint_velocity/cmd_vel topic.

I tried going through the code to understand it but as someone new to ros and python it was pretty confusing for me.

Can you explain why it is behaving like that or am I doing something wrong on my end? Would like to use the setpoint velocity topic rather than having to publish to multiple rc_inputs to control my BR2. Thanks!

Regards
Ashley

(Jacob) #2

The velocity commands are only accepted in GUIDED mode. You need a gps position.