Propeller screws stuck on a new thruster

I want to switch a CW prop to a CCW prop on a new thruster.
I tried using a 2mm hex allen key to unscrew the two screws as per the tutorials but the screws wont budge, Im afraid of stripping the screw heads.

I tried applying WD40 and letting it soak in for a while but this didnt help. What could be going on? How can I get them off?

Hi @LouisM, welcome to the forum :slight_smile:

I wasn’t sure on the best steps here, so asked about it internally. The advice I got was

  • discontinue using WD-40:
    image (2)
  • maybe try heating the screw with really warm water
  • if the screw head gets stripped while trying to remove it, you can cut a slot into it and use a flat-head screwdriver to remove it
  • if by “new” you mean “unused, fresh from the box” and you’re not able to get the screws off you can contact our support email ( with your order number, and be provided with a rotor and screw replacement
    • generally the screws shouldn’t be that hard to remove on a brand new thruster

Hi, thanks for the advice!
I ended up cutting a slot in the screws and they came out ok, there wasn’t any locktite or anything, they were just really tight.
They were out of the box but I had run them for a short period to test the escs etc, in any case, getting a replacement is unnecessary.

1 Like