Problems with Bar30 and ArduSUB on Pixhawk 4


I’m trying to build an ROV which should hold the depth and control the pitch angle in an aquarium.
I’m able to read the ATTITUDE values with a Python-script.
For the depth I tried to connect the new ordered Bar30 to my Pixhawk. For that I needed to change the plug to the new I2C one.
After solder the wires together like the descriptions said, I plugged the sensor in, but calibration fails on ardusub.
I changed the software to ardupilot and there the calibration was succesful, but i cant read any data.

I hope for some help to get the sensor work under ArduSub.

Thanks for ur help.



You may need to change BARO_EXT_BUS so it is able to find the sensor in the correct bus.
I’m not sure of what is the correct bus in the Pixhawk 4, so you may need to experiment.

If you get it working, please report back so we can add that as a default in the Firmware.

Thank u for ur fast answer.

I tried the possibilities disabled, bus 0 and bus 1, but no one worked for me.
I’ve already tried it because of other entries in the forum.

It says:
‘Requesting pressure calibration…
Depth sensor is not connected.
Pressure calibration fail’

The Pixhawk 4 seems to have 4 i2c buses, so try to increase it up to 4. and reboot the autopilot each time.

Have you tried -1?

Hi @Hans12323, welcome to the forum :slight_smile:

The Pixhawk 4 hasn’t been supported until very recently, so there isn’t a stable release for it. To use it with ArduSub you’ll need to use the Development release (ArduSub 4.2) or the Bar30 won’t work, as covered in this thread:

1 Like

After changing to the dev build 4.2.0 and putting the BARO_EXT_BUS to 3 the calibration finally works.

Thanks guys, keep up your great work.


A post was split to a new topic: Absolute Pressure Error

I’m having trouble getting the bar30 to appear in qgroundcontrol. At first I was facing an issue with the bar30 and the leak sensor. After looking thru the forums, I learned that I needed to flash the dev build for the pixhawk in order for the bar30 and leak sensor to work. Thankfully, the leak sensor worked but not the pressure sensor. I think the issue might be in the parameters. I have set everything to desfault and tried experimenting with the bus number like someone else did but that didn’t work. I set it so that looks for my bar sensor [MS5837] but that didn’t work. I looked in mavlink inspector and confirmed that there was no connection. I have all the hardware stuff down so it’s definitly either software or parameters. Seeing as how I flashed the lastest build and the leak sensor work, I’m sure it’s parameters but I dont know what to do.

Hi @Loading, welcome to the forum :slight_smile:

I’ve moved your post here because it’s on the same topic.

  1. Can you please try setting BARO_EXT_BUS to 3 (as discussed above), and see if that resolves the issue?
  2. If it doesn’t, please try flashing on the ArduSub-4.1 (stable) firmware (which was recently released, and should be Pixhawk 4 compatible)?