Home        Store        Learn        Blog

Problems building ardusub, cygwin, windows, waf

Hello,
I followed the installation instruction from here: http://ardupilot.org/dev/docs/building-setup-windows.html
and so far everything worked fine.
I checked out the firmware and switched to branch Sub-3.5.

Configuring with waf was smooth, but compiling fails - see here:
https://pastebin.com/GHp0fv73

Any ideas or comments what I’m doing wrong?

best regards,
Mike

Hi all,
I tested an tried to get further to the problem and now I found that it seems that the module PX4Firmware is missing. But I’m sure it’s there … see:
https://pastebin.com/5iBzEAik

Any help’s really appreciated!

Thanks in advance,
Mike

After changing the branch to Sub-3.5, have you done the update of the submodules ?
git submodule update --init --recursive

Hi Patrick,
thanks a lot for your quick response!

I’ve tried again the full process, also with the initialization of the submodules. See the log here:
https:// pastebin.com/LDSgud5Y

I also tried to checkout ArduSub-stable, updated and init, recursively the submodules and tried to build it.
So far the same error …

Any ideas?

Thanks and best regards,
Mike