Prearm Failure (Blinking Yellow)

According to this post our Navigator board is failing the prearm and we don’t know why.

Presented Symptoms:

  • Not getting MAVLink heartbeat in blue os.
  • Not able to connect to QGroundContol.
  • Getting options of Navigator board and SITL board for autopilot.
  • Sometimes not detecting a board for autopilot.

What We’ve Tried:

  • We opened up Blue OS to see if it was a problem we could fix on there but we couldn’t figure it out and in this process we found out that we are not getting a MAVLink heartbeat most of the time. We also found out that we aren’t getting an autopilot board all the time. When we do get a board it automatically has the Navigator board selected but we have the option to switch it to SITL. We don’t know which one we should be on or if there should be another one we should see and select. We also have also reinstalled Arudsub on both boards (version 4.1.0) and nothing changed.

Update: We reinstalled the softwear again but it isn’t information from the compass or accelerometer. When we try to calibrate the accelerometer we can get the first step done but when we try to calibrate it leaning to the left it is saying calibration failed and that a log will be shown. But we don’t know where to see the log and can’t find where to see the log. Is there a way to see if the accelerometer is working or not?

Hi @cece, apologies for the delay on getting to this one.

Hmm, that’s not good. Are you able to provide a log from the ardupilot manager service? If you’re on the latest BlueOS beta image (1.1.0-beta.16) you can access that from Tools / File Browser, then going to system_logs / ardupilot-manager, then clicking the “Last Modified” column heading to sort the logs.

When you’re in Pirate Mode it’s possible to run a simulation of the vehicle (using “software in the loop” (SITL)). If you’re trying to use the actual vehicle hardware you should be on the Navigator board.

Is it specifically not getting the sensor information, or is it not getting any of the telemetry (e.g. camera tilt, tether turns, pilot gain, etc)? If there’s no telemetry that would be consistent with some form of connection issue, or a problem with ardupilot manager not working properly. If you’re only missing the data from your sensors then that seems like a sensor issue - as far as I’m aware the sensor data should still be sent even if the sensors aren’t calibrated, so if there’s no data from them then they might be malfunctioning or something.

That sounds like the vehicle is at least responding meaningfully

I’m not sure what the idea is there - I tried purposely failing a calibration and it gave me the same message, but it doesn’t appear to have created a log anywhere in QGC’s output files.

Note that accelerometer calibration should have the orientation of the autopilot (within the vehicle) set first, and then during the calibration process the focus is on keeping the autopilot still when the “next” button is pressed (which is more important than getting the angle exactly right).

If you’re getting telemetry data you can go to QGC’s Analyze Tools / MAVLink Inspector, select the RAW_IMU message, and look at the xacc/yacc/zacc values (you can click the plot checkbox if that’s helpful) as you shake the vehicle around a bit in each direction.