Power loss and now no connection

We can ping to the raspberry and ssh to it, nevertheless we cannot Visit blueos.local or connect the pixhawk to qground.

pixhawks leds are alternating between yellow and purple.

Ok, that’s a good start. Do you know which software you’re running on it? Assuming you’re sshing via pi@192.168.2.2, can you try http://192.168.2.2 and http://192.168.2.2:2770 in a browser, to see if either one brings up a web interface?

Ok, so the Pixhawk is definitely receiving some power then, and operating a firmware enough to have a status. Not sure what yellow and purple means (that’s not one of the options in the ArduCopter Status LED docs), so I’ve asked internally whether ArduSub has a specific one that isn’t documented or something.

yellow and blue

Leak failsafe

EKF failsafe

GPS glitch

Radio/GCS/Batt failsafe.

the battery and charger i ordered just arrived a few mins ago. a day early

Nothing has ever been removed since we originally tested when it comes to those wires. if I recall its the light blue wires and one has white line on it.i checked that every time thinking maybe they are crossed.
when we were delivering very minimal power we had a power drop out and disarm on QGC.

correct with sshing pi@192.168.2.2 , http://192.168.2.2 and http://192.168.2.2:2770 those do not open for us.

A post was split to a new topic: Battery Thermistor Wires

I just tried on my own setup and the leak failsafe is apparently yellow and purple, so presumably you don’t have a leak detector plugged in, or at least it’s not plugged in to the configured port (which should be unrelated to connectivity issues).

Alright, fair enough

You seem to have quoted this without responding to it.

Raspbian

If you are running pure Raspbian without running BlueOS or our Companion software then your Raspberry Pi will have nothing that is trying to connect to the Pixhawk or create a web interface - that’s like buying a new computer without QGroundControl or a web browser installed, but expecting it to still allow you to control an ROV. If that is indeed the case, please try installing flashing either

onto your Raspberry Pi’s SD card, and seeing if it connects to your Pixhawk and provides the expected web interface to the surface computer :slight_smile:

using battery power now. the exact same is happening, no connection. I used the usb to micro usb that connects the pixhawk and raspberry. nothing happened on the mac at all. used my old laptop with windows 7 in it and qgroundcontrol allowed the pixhawk connection. thats where im at now. then i plugged everything back together and used the known good port on the windows laptop and got no connection again. Where do i go from here? it wasnt a power issue like i hoped it was.

Flashed blueos and still the same thing. No connection.

Flashed to blueos. Didn’t work. Uninstalled qground and went to reinstall and got errors non stop. So I reverted back to a copy from last year. Qground works again on my desktop. Reflashed to arsusub. Ardusub and an old version of qground and everything is now working as it should. Still nothing is connecting to the Mac for some reason.

It’s working as it should now :blush:

This is confusing me. ArduSub is autopilot firmware that runs on the flight controller board (e.g. Pixhawk), whereas BlueOS is software that runs on the onboard computer (Raspberry Pi). Are you saying you tried flashing BlueOS onto the Pixhawk, instead of onto the SD card in the Raspberry Pi?

What kind of errors, and what operating system were you installing it onto? As far as I’m aware our latest recommended version of QGroundControl should work on Windows, Mac, and Linux, so if it’s not doing so then there’s either something problematic with your computer’s configuration, or there’s a bug we don’t know about that should ideally be reported and fixed.

Well, a working system is definitely a good point to be at :slight_smile:

1 Like

no. i flashed the raspberry with ardusub from this page. Installing Companion Software Image · GitBook I havent messed with flashing anything on the Pixhawk. Are you saying the Pixhawk should be flashed with blueos?

I did take a few pics of errors as they happened. Pretty much every aspect of the install had to be ignored in order to move forward. I clicked ignore atleast 50 times just to see. I knew the install would t work.


still cant open these pages to use the web interface.

side question. Thrusters sat out of the water for the last 5 months and now they sound terrible when testing them. i have a known spare esc i will use to test on to see if the escs are bad. makes sense that i had to replace all the other electronics. i have enough on hand to replace them all if needed. just hoping its not the thrusters. cant spend another $1800 on thrusters this month.

Companion Software and ArduSub are not the same. That page is for the Companion Software, which is one option for flashing onto the onboard/companion computer (Raspberry Pi). ArduSub is firmware that runs on the flight controller board (e.g. Pixhawk). There’s a diagram here.

Nope, BlueOS is a replacement for the Companion Software, and runs on the onboard computer (Raspberry Pi).

Given it’s complaining about an error opening the file for writing, perhaps there was already an existing installation that the new install process was clashing with?

Since you said you’ve installed Companion, can you go through our troubleshooting steps and provide the results/output of each step/test?

Are you testing in air, or water? From the T200 product page:

Do they spin smoothly by hand, when they’re not powered? If not then there may be something caught in them (e.g. seaweed, fishing line, mud, etc). Depending on how and where they’ve been operated previously there’s also some possibility they’re damaged internally and have a buildup of rust, in which case they’ll likely need replacing.