Home        Store        Docs        Blog

Ping Firmware update

#1

I have been trying to update the firmware on the Ping from 3.24 to 3.26 and am getting no response from the update button.

I’ve cycled the ROV and redownloaded pingviewer, and have tried connecting the serial port directly to my computer.

The altimeter is connected and I’m getting good readings from it, but when I try and update it stays on the idle animation. I’ve even downloaded the hex file and tried to manually update but the same thing happens.

Any advice is appreciated
Thanks!

(Patrick José Pereira) #2

Hi Steve,

Can you send ping-viewer log when you try to flash the sensor ? Any log could be important, you can read more about the interface logs and the folder structure here.

#3

Hi Patrick,

Here are a few of the logs. Thanks for looking into this.

20190219-115520642.bin (375.3 KB)
20190219-120837458.bin (18.3 KB)
20190219-121312995.bin (282.2 KB)

(Patrick José Pereira) #4

Hi Steve,

This are the logs of the sensor and not of ping-viewer, take a look in the Gui_Log folder.

#5

Hi Patrick,

Whoops sorry about that. Here you go:20190219-104236940.txt (842.5 KB)
20190219-120653647.txt (174.1 KB)
20190219-121300024.txt (203.7 KB)

(Patrick José Pereira) #6

Hi Steve,

From your logs, it appears that you are trying to flash the sensor connected via UDP from the ROV, right now it’s only possible to flash the device with Ping-Viewer via serial and direct connection with your ground station computer.

#7

Hi Patrick,

I was trying to update it through the UDP, I also tried connecting my computer directly to the blueart adapter and it didn’t work (is that what you mean?). When i connected the USB it recognized the new com port but I couldn’t get a connection with either baud rate.

Sorry if these are silly questions, I don’t know very much about electronics.

(Patrick José Pereira) #8

Hi Steve,

No problem, we are here to help you.
Try the following:

  • Disconnect your computer from the ROV
  • Connect ping directly in your computer
  • Open Ping-Viewer and wait for some seconds and the display should update automatically
  • Try to update the device normally

All logs that you sent shows Ping-Viewer connecting to the ROV, try to send the log with this simple test if it fails to connect/flash.

#9

Hi Patrick,

Sounds great, I’ll give it a shot first thing tomorrow. Just to clarify, I’m connecting the usb from the blueart to my computer right?

Thank you very much for your help!

(Patrick José Pereira) #10

Hi Steve,

No problem, yes, you should connect Ping in your computer with BLUART.

#11

Success!

When I connected directly to the ping (and disconnected the tether connection to my computer) the update worked.

Thank you very much for your help (and patience)!

1 Like