Ping 360 USB Config not recognised by Ubuntu 22.04, not detecting device at any ports

I am trying to use my new Ping 360 for the first time:
-NUC I7 with Ubuntu 22.04
-powered by power station
-usb configuration

I have checked the wiring on the PCB and that seems fine. Also the Sonar blinks red upon applying the power from a power source.
I have tried to find a serial connection on multiple devices, but with no success.

Upon plugging in the ping360, ping viewer does not find any devices and I cannot find the serial device anywhere via the terminal.
dmesg | grep ttyS: gives no output
ls /dev/tty*:

/dev/tty    /dev/tty23  /dev/tty39  /dev/tty54      /dev/ttyS10  /dev/ttyS26
/dev/tty0   /dev/tty24  /dev/tty4   /dev/tty55      /dev/ttyS11  /dev/ttyS27
/dev/tty1   /dev/tty25  /dev/tty40  /dev/tty56      /dev/ttyS12  /dev/ttyS28
/dev/tty10  /dev/tty26  /dev/tty41  /dev/tty57      /dev/ttyS13  /dev/ttyS29
/dev/tty11  /dev/tty27  /dev/tty42  /dev/tty58      /dev/ttyS14  /dev/ttyS3
/dev/tty12  /dev/tty28  /dev/tty43  /dev/tty59      /dev/ttyS15  /dev/ttyS30
/dev/tty13  /dev/tty29  /dev/tty44  /dev/tty6       /dev/ttyS16  /dev/ttyS31
/dev/tty14  /dev/tty3   /dev/tty45  /dev/tty60      /dev/ttyS17  /dev/ttyS4
/dev/tty15  /dev/tty30  /dev/tty46  /dev/tty61      /dev/ttyS18  /dev/ttyS5
/dev/tty16  /dev/tty31  /dev/tty47  /dev/tty62      /dev/ttyS19  /dev/ttyS6
/dev/tty17  /dev/tty32  /dev/tty48  /dev/tty63      /dev/ttyS2   /dev/ttyS7
/dev/tty18  /dev/tty33  /dev/tty49  /dev/tty7       /dev/ttyS20  /dev/ttyS8
/dev/tty19  /dev/tty34  /dev/tty5   /dev/tty8       /dev/ttyS21  /dev/ttyS9
/dev/tty2   /dev/tty35  /dev/tty50  /dev/tty9       /dev/ttyS22
/dev/tty20  /dev/tty36  /dev/tty51  /dev/ttyprintk  /dev/ttyS23
/dev/tty21  /dev/tty37  /dev/tty52  /dev/ttyS0      /dev/ttyS24
/dev/tty22  /dev/tty38  /dev/tty53  /dev/ttyS1      /dev/ttyS25

I also tried using a script to find connected devices:


for sysdevpath in $(find /sys/bus/usb/devices/usb*/ -name dev); do
        devname="$(udevadm info -q name -p $syspath)"
        [[ "$devname" == "bus/"* ]] && exit
        eval "$(udevadm info -q property --export -p $syspath)"
        [[ -z "$ID_SERIAL" ]] && exit
        echo "/dev/$devname - $ID_SERIAL"

this script only returns the wireless kezboard and mouse:
/dev/input/event3 - Logitech_USB_Receiver
/dev/input/mouse0 - Logitech_USB_Receiver
/dev/input/event4 - Logitech_USB_Receiver

but it will find usb camera plugged in.
Is there a issue with one of the shipped components?

Any help is much appreciated. :slight_smile:

Hi @debaumann, welcome to the forum :slight_smile:

Not sure what’s going on here, and I’ve asked internally and had a similar response.

The Ping360 contains an FTDI serial to USB converter, which is quite a standard component, and the FTDI VCP driver is built into the Linux kernel so should be available.

If nothing connects then there’s likely some kind of hardware issue, either in how the wires are connected (e.g. if RX and TX are swapped, or if the Ping360 cable has been moved from the USB connector to the ethernet or RS485 connector), or a problem with the device or your computer’s USB port.

If you’re still having issues with this then I’d recommend contacting our support email ( and letting them know what’s going wrong, and what you’ve tried so far (linking to this post is fine), as well as your order number (or at least a rough order date).