Home        Store        Docs        Blog

Over voltage when charging

Hi,

I do not succeed in charging one of my 3 batteries anymore. When I plug it to the BR2 charger, no matter what mode I chose (charge, balance charge, discharge etc), it outputs “Vout over” as if I had an over voltage in one of the cell maybe. I used the battery for a mission just before, it is at 15.5V roughly.

Does it mean this battery is dead? What can I do otherwise?

Thank you

Hi Steven,

Is the charger correctly detecting it as a 4S battery?

Hi William,

It is recognized as a 3S indeed when I plug the balance charge wires. I figured out I can still charge it in normal charge if I unplug the balance wires.

Cordialement,

Best regards,

image003.jpg

image004.jpg

Hi Steven,

I advise against charging without balancing, as on the long term it could overcharge some of the cells.
You probably had a wire of the balancing plug damaged. it may be fixable.

Best regards,

Hi,

Ok thanks, I will have a look on that.

Cordialement,

Best regards,

image003.jpg

image004.jpg

I have similar issues with my charger.

I have tried in three different batteries and all are giving me cahrging port error. Voltage error.

The charger just recognize 3 cells out of 4.

Let me know how goes checking the port. I might have similar issues.

Regards
Luis

Hi,

Yes we soved it by cutting the connector on the faulty cable and solding it back in the JST xh connector. But I have got now a new problem as I have oxydation on the negative pole and on 3 out of the 4 balance connectors after I use dit on a dive, cannot explain why, some current leak somewhere I guess, maybe because of a bad solding I have no clue.

Cordialement,

Best regards,

image003.jpg

image004.jpg