Not getting Doppler Velocity in DVL values


I am using a DVL A50 with the BlueROV2 (R4 version). All my network connections are working properly and I am getting a steady green light on the DVL. However, this is the how the dashboard is when I run the robot.

I am getting the dead reckoning values but not the Doppler Velocity. Here is a snippet of the recorded JSON values as well for reference:

data: "{\"ts\":1550142481.8864772,\"x\":0.4763551030519053,\"y\":-1.2124421059259085,\"\
data: "{\"ts\":1550142482.1119018,\"x\":0.48200987595900496,\"y\":-1.191128443312616,\"\
data: "{\"ts\":1550142482.3367517,\"x\":0.5281306243185511,\"y\":-1.188227158108969,\"z\"\
data: "{\"ts\":1550142482.5369565,\"x\":0.5534075029274759,\"y\":-1.2150575593490816,\"\
data: "{\"ts\":1550142482.7618692,\"x\":0.5868714445115497,\"y\":-1.2122991573285484,\"\

Kindly let me know what can be done to get the doppler velocity values.


Hi @kjoshi,

Given the DVL is reporting that its velocity estimates aren’t valid, the extension will be ignoring those estimates instead of passing them on to ArduSub (because otherwise it’s feeding effectively random numbers into the state estimator).

There’s some reasonably in depth discussion of getting valid velocity readings in this comment, which will hopefully help :slight_smile:

Hi Eliot,

I will try this next week. My I/O interface board for the DVL A50 stopped functioning so I have ordered a new one. I will let you know if that works once I get the new board. Thank you!

1 Like

Hi @EliotBR,

I followed all the steps which you had mentioned in the comment. I am still unable to get a valid velocity reading. The only thing working is the dead reckoning for the DVL-A50. The firmwares are as follows:

AutoPilot: 4.1.0 (beta)
BlueOS: 1.1.0-beta.13
Waterlinked DVL-A50: 2.2.1 (I tried it with 2.1.0 as well but same problem)

Kindly let me know what can be done.

This is a DVL and/or usage problem, and is unrelated to how it interfaces with the Blue Robotics side of things. Unfortunately my description of theoretical ways a DVL may fail to attain good/valid readings is about the extent of the help I can provide on that front.

From your initial screenshot it’s reporting a 0Hz ping rate which presumably means it’s not fully enabled, or some part of it isn’t working properly. Maybe try going through the user guide again, to make sure you’ve followed all the necessary setup steps?

Perhaps @wlkh or someone else from Water Linked has some further advice or insight :slight_smile:

1 Like

Thanks a lot for you response.

I have raised a ticket with Waterlinked for this issue and I will try to get some assistance from there. I will update it here whenever I find a solution

1 Like