Home        Store        Docs        Blog

Need some help!


(Brian Livingston) #1

I have a kayak that I built last year for remote bait drops for fishing. To start I had a monster Hitec Servo and gear reduction for steering turning a minn Kota trolling motor and of course throttle. With the pixhawk as my controller and a futaba t7c. Worked just fine. But I didn’t want to use a trolling motor anymore, I decided to go with a skidsteer setup. So I bought 2 t200 motors. I love them. Small, lightweight, out of the way when in transport (unlike the bulky minn Kota) but I’m having issues. I set everything up in mission planner for the skidsteer like it says, channel 1&3 it works OK in guided mode on my phone, but uncontrollable in manual. I’ve read all over where everyone is using things like sabertooth for the dual motors, but I believe they are only for brushed motors? So my question… What do I need to do to get perfect control of the 2 t200 motors with the pixhawk skidsteer? Please help.


(Kevin) #2

Hi @Bigbri

No problem, we’ll get you fixed up!

  1. Which ESCs are you currently using?
  2. Which version of ArduRover are you using? ArduRover had a fairly recent major revision and there are still some kinks being worked out. The ArduRover 3.2 and ArduBoat forums have quite a bit of firmware troubleshooting.

From personal experience, ArduRover with skidsteer is really picky on its set-up. You basically need to have all parameters set to default when getting the steering working. Meaning, your inputs from your Futaba radio need to be set to “normal” and not “reversed” and your Pixhawk firmware parameters also need to be set to “normal” and not reversed channels.

Set it up in manual mode first. If there is a channel reversed when you push your throttle forward and one of your thrusters goes a direction opposite of what you want, manually switch two of the wires going from your ESC to the thruster. This is the hard wire method of switching thruster direction. This should fix your issues.

Once manual mode works well, then try it with auto and guided.


(Brian Livingston) #3

Ok thanks a bunch I’ll give it a try. And I’m using APM: Rover V3. 2.1 and 2 hitec esc’s


(Brian Livingston) #4

Another question, with the differential motor setup, is there a motor controller I need to be using with or instead of the esc?


(Kevin) #5

No other hardware is required between your Pixhawk and ESCs. I don’t know what sort of results you will get with your Hitec ESCs and if they have a reverse , but if you have problems, try our Basic ESCs. I’ve been using the Basic ones in my surface vehicles for years without issue.

I reached into my picture archives and found the following if it helps with visualization at all.


(Brian Livingston) #6

Thanks again for the help. I did what you said and it’s working. I don’t have reverse with the hitec esc, so I ordered a couple basics. They should be here today. But after getting it going I noticed my throttle failsafe isn’t quite right, it’s set to rtl when signal lost, so when I switch the radio off, channel 3 shuts down while channel 1 stays at 50% is there a way to have both respond the same? Because technically they are both throttle now, left and right. Or is it in my radio? Again I definitely appreciate the help.


(Kevin) #7

No problem, glad you got your vehicle working!

From what you have described, that sounds like it may be a firmware issue with the RTL flightmode. If the issue persists after you switch to the Basic ESCs and you’ve made sure that all your trims and everything are zeroed out, I’d recommend starting a thread over on the ArduPilot forums with your parameters file. They should be able to troubleshoot the firmware.


(Kevin) #8

@Bigbri One thing we’ve been thinking about here is that there is still and issue with the firmware and skid steer. Something you may want to consider is changing the frame back to conventional steering (throttle and rudder) and installing a servo mixer in between the outputs on the Pixhawk and the ESCs. Here are some examples of “tank-style” mixers: IMX-1 Mixer, Mtroniks Tank Track Mixer.

I just bought one of the Turnigy V-Tail mixers off Amazon because they are easy to get. When it comes in, we’ll test it and see if it works and let you know.

Rover was created from Plane, so our thinking is that skid steer is messing up the flight modes and it will probably work best with everything on stock settings. What I’ve outlines above is simply the hardwire method of servo mixing for differential thrust setups.


(Brian Livingston) #9

I’ll have to give that a try when I get the motors working. Everything was good until all of the sudden both t200 motors stopped working. One absolutely nothing. And the other one just shudders and resets. But those mixers are definitely cheap enough, thanks for the tip!