Home        Store        Docs        Blog

My T100 thruster does not make any noise or move.

Hello. I’m Takuma.
The other day, I got a T100 thruster and a basic ESC in Japan.I wanted to get it and check the operation right away, but my T100 didn’t move.
I confirmed many times that my program and wiring were wrong, and diverted a program that had been answered in this forum in the past. I think there are all right, but T100 does not move.

While investigating, I made a discovery. Several people say that a beep sounded when the T100 / ESC was turned on. But my T100 does not emit any sound. Is this something related? Is there anything that can be considered as a cause of T100 not working?

My English may be funny. I’m sorry.
best regards.

Hi @SkyBear Can you please post a picture of your set-up?

Hi @kklemens . Thank you for your reply.

Of course!
And these are some of the programs that I have tried.

①https://discuss.bluerobotics.com/t/rasbperry-pi-3-and-t100-thrusters/1342/7

import time
import wiringpi
wiringpi.wiringPiSetupGpio()
wiringpi.pinMode(19, wiringpi.GPIO.PWM_OUTPUT)
wiringpi.pwmSetMode(wiringpi.GPIO.PWM_MODE_MS)

wiringpi.pwmSetClock(192)
wiringpi.pwmSetRange(2000)

wiringpi.pwmWrite(19, 150)
time.sleep(7.0)

wiringpi.pwmWrite(19, 170)

import time
import sys
import pigpio
pi =pigpio.pi()

pi.set_servo_pulsewidth(19, 1500)
time.sleep(7)

pi.set_servo_pulsewidth(19, 1700) time.sleep(5)

pi.set_servo_pulsewidth(19, 1500)
pi.stop()

JointPics_20190811_002449|333x500

Please help me…
No solution yet found…

A couple things:

  1. I recommend verifying your hardware (Thruster and ESC) first if you are having startup issues. Use a servo tester or Thruster Commander to verify that your Thruster and ESC are good.
  2. Twisting and taping wires together isn’t very secure, I recommend something like screw terminal or electrical connectors.
  3. After you verify your thruster and ESC are good, your software program may need work.

Hi @SkyBear,

When the ESC starts up, do you hear the startup beeps? It looks like you’re using pifferent power sources, make sure you have a common ground between you control system power and ESC power.

-Adam

Hi ! Thank you for your reply !
I tried the advice of two people, but the thruster did not move.
However, because I had little time left, I bought a basic ESC again, considering the case where the ESC was out of order.
The new ESC worked without any trouble… I may have been unlucky…
Thank you for answering !