Home        Store        Learn        Blog

My first ROV dives

I just built a BlueROV2 heavy and took it out for the first time this weekend at Lake Coeur d’Alene. My primary goal was to just get familiar with the controls and do a little exploring. I though I would share this video since there doesn’t seen to be a lot of dive videos here. I bought it for personal recreational exploration, so hopefully I will make a ton of videos from the lakes and rivers in the Pacific Northwest.

Let me know if anyone has any general tips or ways to improve the video stream quality.

https://youtu.be/7VWZbofnkqs

2 Likes

Nice dive, looks like you would’ve had fun!

Re streaming quality, is the display in QGC clearer than the output stream from OBS, or is the issue with the quality coming up from the ROV?

For the former try increasing the stream bitrate (settings in the bottom right of OBS, click stream on the left menubar, up the number to say 4000), or possibly try adding a noise suppression filter if you mostly care about smoothness (click your desktop Source, then Filters (next to Properties, just above the Sources section), click + (above Effect Filters) and add the filter you want. RNNoise is relatively new but apparently works better than Speex (if you don’t have it try to update your OBS - I only got the update this morning).

If the problem is with video from the ROV then a noise filter in OBS might still help, but you also might want to check that you don’t have any scratches on your dome, check the CPU Load (can check at http://192.168.2.2:2770/system while operating) to see if it’s struggling, and possibly check for corrosion on your wires, and look into your gstreamer parameters (if you’ve changed them) to check that there’s no slow or quality-reducing stuff going on. Oh also, might be useful to tune the camera display profile at http://192.168.2.2/camera if you’re having particular colour or brightness/contrast issues.

1 Like

I’m a little dissapointed in the quality from the ROV. The video stream looks really ‘soft’ (not sharp) for being 1080p and is usually really grainy. I did check the camera settings and it is set to 1920x1080 at 30FPS. Maybe I just had unrealistic expectations for the camera since I know it does trade image quality for better low light performance. It was hard to see anything at night because there was either a ton of backscatter with the lights up, or the video was dark and grainy with the lights down.

I might just need to get used to it and possibly get a laptop with a very bright screen. I really appreciate your tips!

Try adjusting the focus of the lens, and maybe look into the sharpness and backlight compensation factors on the camera weblink :slight_smile:

Screen brightness can be an issue, but you also might want to look into changing the camera profile (e.g. brightness/contrast/gamma) on the weblink if it’s not currently well set up for your operating environment. You can also look into adding effects directly to your stream in OBS, but that means you only get to see the results afterwards which isn’t nearly as helpful as just having a corrected live display.