Home        Store        Docs        Blog

Low Light USB camera and Win10?


(Tim Hutcheson) #1

Can the Low Light USB camera be accessed from my laptop running Win10? It doesn’t install as a webcam although the information I have seems to suggest that it will. Do I need a special driver?

Thanks,

Tim


(Jacob) #2

The is a UVC compliant. Most operating systems include a driver for these type of cameras. Try this: http://support.logitech.com/en_us/article/Install-native-UVC-drivers-for-your-Logitech-webcam?product=a0qi00000069uigAAA


(Tim Hutcheson) #3

Symptom is that while it works fine on RPi3, win10 doesn’t even respond to inserting the usb connector much less install a driver. Doesn’t show up in device manager in any form.


(Jacob) #4

This indicates some problem with windows or your usb port.


(Tim Hutcheson) #5

I can plug other USB WebCams in and they are recognized behave normally. So should I interpret your response to mean that you know and have verified that it does work with Win10? For example if I go to the link you recommended and follow the instructions, the camera does not appear as a USB device (or any device for that matter) in the Device Manager at all, which is generally the first step to updating or installing a driver for a device, at least to my recollection.

Thanks for taking your time to look at this.
Tim


(Kevin) #6

Hi Tim,

I’ve plugged these HD USB cameras into my computer, which is a Windows 10 and they work fine. I concur with @jwalser that you may be having a port issue on your computer, or you may have a setting on your computer preventing you from installing new drivers? I’ve seen that before on enterprise manged systems. You can check here to see if your computer allows for automatic driver installs.


(Tim Hutcheson) #7

Yep, thanks for the heads up, Found it, fixed it.

Tnx again.

Tim


(Tim Hutcheson) #8

Not so fast…!!

After managing to get it working while chasing around in group policies, etc, runing gpedit.msc, I was able to use Yawcam app to record frames. But thought I had it fixed and rebooted the machine - yikes, not detected again and no amount of poking with gpedit seems to restore it again. So somehow I had it enabled but lost the magic.
So this morning I tried the registry hacks that I cold find related to the Microsoft WIN10 Anniversary update issue that broke the H.264 streaming mechanism and that didn’t seem to be related. So back to square one but now know for sure that my Blue Robotics Low Light works fine - just can’t seem to use it on WIN10 with all updates. Maybe I will rollback the OS but reluctant to go that path if someone else can offer a better solution. Yes, I know - Win7… :slight_smile:


(Jacob) #9

:grimacing:


(Jacob) #10

Why do you want to use it with windows? Maybe just reinstalling windows 10 will work.


(Tim Hutcheson) #11

i Jacob.

I have it running on the RPI3 fine but need to do some dockside development using our Matlab toolboxes. The Octave version in the ROV is a “watered down” version (pardon the pun) but I need the laptop for this.

Any help is appreciated very much. As I said it is mystery why it doesn’t even get recognized as USB device in the Device Manager and this is true for three machines I tried this morning: one WinXP, another Win 7 and yet another completely different Win10.

So I have come in a complete circle and back at square one in spite of having it work briefly for about half hour using Yawcam app.

Tim


(Tim Hutcheson) #12

Just to follow up, I installed a Logitech Webcam without problem. So I know that installs fine without any system changes or repairs, shows up as an imaging device and operates in Yawcam. And I also know that in some circumstance, the BR low light will show up and operate in Yawcam but don’t know what the circumstances are.


(Terry Eglinton) #13

Tim, have you had any success? I have a similar issue.


(Tim Hutcheson) #14

No, I reconfigured my experiment to use a Logitech webcam inside the housing - with a little 3D printer help. :slight_smile:


(Terry Eglinton) #15

Thanks.