Home        Store        Learn        Blog

Lost Manual control

Hi,
Since the last updates (QGC4.0.5, Ardusub4.0.1, Companion 0.0.21) I have this message too often, sometimes nothing for 10 minutes and suddenly it starts again.
In safety parameters it is 3s
An idea ??
Thank you

After the update we did yesterday, we started having a similar problem. Imu sensors give an error. Then pixhawk commands take 2-3 seconds delay.

We formatted Pixhawk’s sd card several times but it didn’t fix our problem. We’ll be working on another pixhawk tomorrow. If we can fix the problem, I’ll post it here.

1 Like

Hi @enis.getmez,

What do you see on http://192.168.2.2:2770/mavproxy? The high delay was linked to a high streamrate and too many endpoints there.

We tried changing the pixhawk and the problem wasn’t solved. We formatted the Raspberry pi many times. There is no change right now.

We are sure the problem is caused by raspberry pi. Pixhawk works smoothly when we connect pixhawk with usb cable. There is no delay in the Raspberry pi camera view. We only get delays while transmitting commands to the pixhawk.

What is the cpu usage like?
Try removing the line ending in 14660 (ping360 heading integration) or 9002 (mavlink2rest, this will disable mavlink2rest)

1 Like

We solved the problem. Normally raspberry pi is powered by 2 different power sources. But we forgot our 1 power supply after removing it from raspberry pi and plugging it into servo motors. Therefore, raspberry pi received low voltage warning and was not receiving our commands due to high cpu. Now when I plug the power supply back in, everything is fine.

1 Like

Hi all, I also got a similar problem today. (using 0.22/0.21 companion version)

The thruster commands take some seconds delay, and the streaming video is working fine. However, after unplugging the USB camera, it (the pixhawk commands) returns to normal.

I think it is due to high CPU problem of rpi2 (60-70% cpu usage, I login via ssh and use the “top” command to watch), when I decrease the video resolution and frame rate of the video streaming, the problem is alleviated.

So my question is:

  1. Is the power voltage problem cause this problem? I am using a power transformer (12V -> 5V, 2A) to power the raspberry pi via the GPIO pin. (I also try to power the raspberry pi using a USB port of a laptop, But this problem still occurs) . Is there anything wrong with this approach to power the raspberry pi?

  2. The almost-the-same solution of my electric housing was used last year but it performs well (and use the companion firmware downloaded last year, but I did not notice the firmware version). So could it be caused by the new companion version?

Thanks in advance for answering my question!