“Failed to Initialize Ping!” when trying to run sample ping-python code on Ping2 Sonar

Hi, I am attempting to use the Nvidia Jetson Nano with the Ping2 Sonar. To connect the sensor, I am using a BLUART USB to TTL serial converter.

The Ping2 Sonar does connect to the computer, but it fails to initialize whenever I try to use ping-python or ping-cpp to initialize the device. You can find the repositories here:

I have attempted to run the sample code in several different environments, but the issue persists on all of them:

  1. Jetson Nano with a Docker image running Ubuntu 22.04
  2. Windows 10 laptop
  3. MacBook Air with an M2 chip

I have also searched for similar issues reported by others and tried several suggested solutions, but none of them have worked. I came across this discussion topic ("Ping device failed to initialise" using ping-arduino - #7 by Josh1977) and attempted to use both baud rates, 115200 and 9600.

Additionally, I tried to update the firmware using Ping-viewer, but it displayed a “Failed to Init Device” error message. Following a suggestion mentioned in this thread (Ping interrupted firmware update), I tried to reset the device by running the command “.\stm32flash.exe -v -g 0x0 -b 115200 -w .\Ping_V3.26_115kb.hex COM4.” However, this also resulted in the same “Failed to Init Device” error.

Notably, both the green LED on the device and the BLUART are blinking, indicating that the firmware is working correctly, as far as I can tell.

At this point, I’m in dire need of assistance. Do you have any insights into what might be causing this issue?


Hi again,

Just to clarify, the device that I am using is not the Ping2 Sonar, but the Ping Sonar Altimeter and Echosounder. It has a blue part on the topside.