Home        Store        Docs        Blog

Can't connect to ROV after QGC update to 4.0.5

Hello all-

I upgraded my Pixhawk to v4.0.1, companion to v0.0.20, and QGC to v4.0.5 and now am unable to get communications between the QGC and the vehicle. I did all the original updating through the companion webserver and noticed that the Ardusub version kept showing “Not Found”.

I’ve spent a few days slowly working through all the variables here and more throughly reviewing the other threads out there on similar issues.

After messing with in-place upgrades and seemingly getting nowhere:

  • I directly connected the Pixhawk to QGC to flash Ardusub and that succeeded, as well as now shows in companion webserver the proper version tag
  • I pulled the SD card from the RPi and reflashed it with a fresh image.

After that was completed:

  • The webserver is now showing all the proper versions and information.
  • The mavproxy API page at 192.168.2.2:4777/mavlink is showing data

Most perplexing here is the vehicle still connects fine to QGC v3.5.4 despite all the warnings that I need to upgrade. Reviewing the mavproxy settings in QGC shows active communication happening in 3.5.4 but in 4.0.5 it says “Not Connected”.

What am I missing?

Hi @Lucas. I had the same issue. Here was my post with the solution. Good news, its easy.

Try resetting the mavproxy parameters to their defaults at http://192.168.2.2:2770/mavproxy

1 Like

Hi @Lucas,

Does that happen if you re-open QGC 4.0 with the ROV on?
It could be that the streamrate is not being requested properly.

I had tried various permutations of boot order but went back again just now to try one more time. Booted ROV, then clean booted computer, then loaded QGC. Stil no dice :frowning:

I’m not getting the video feed either, I did go in QGC and set up the camera stream appropriately based on what’s showing in companion (and they were the defaults anyway).

Checked again:

  • mavlink service is running
  • 192.168.2.2:4777/mavlink shows data

@Lucas we’ll reach out in private message to do a remote desktop session with you.

Update on this issue:

The new QGroundControl install had to be allowed through the Windows Firewall. After doing that everything worked.

QGC 3.5.4 worked fine because it was already allowed to listen to the video (UDP 5600) and telemetry (UDP 14550) streams.