Home        Store        Docs        Blog

Camera noise or missing information

#1

I use an H264 format camera. When the camera is directly connected to the computer via USB, video is very clear. But when attached to the raspberry pi, video made a noise like this.


Seems like the message was lost in video transmission.
Frame Size: 1920*1080
Frame Rate (FPS): 30
Upload Results = 92.475Mbps
Download Results = 72.867Mbps
My graphic card is NVIDIA GTX1050.
I tried lowering the frame size and fps.In the process of reduction, the situation was indeed significantly improved, but in more attempts, most of them did not improve, and the shape of noise was changed. I’ve never understood why the same Settings make such a difference.Is there any way to eliminate the noise? It will greatly interfere with my follow-up work.Thanks for any help!

0 Likes

(Willian Galvani) #2

This seems to be a new issue. Can you tell us more precisely what camera is it?
These kind of artifacts are not the typical ones for when h264 loses packages.

How is your raspberry powered? I’m wondering if this could be caused by the camera not getting enough power. You can check in http://192.168.2.2:2770/system if CPU Status shows “Under-voltage has ocurred” as here:

0 Likes

#3

Thank you for your reply. I use the SONY IMX322 camera,which is powered by USB on my pc. It is true that the CPU state is “Under-voltage has ocurred”. But the noise is still there after I use independent power supply.The camera uses 2.0USB, I think I should keep the Frame Size down.

0 Likes

(Jacob) #4

Hi @gyj, we have never encountered this sort of problem before, it should not happen. Please try to use QGC on another computer, and let us know if there is any difference in behavior. This will let us know if the problem is inside of your computer, or inside of the ROV.

0 Likes

#5

I tried it with two computers and two raspberry.The problem is the same. I solved the problem yesterday, When the Frame Size is set below 640*480. The noise will disappear.The problem seems like the video stream was too large. The information could not be transmitted to the computer completely. Since there is no noise when the camera is directly connected to the computer, maybe the problem is raspberry ?

0 Likes

(Willian Galvani) #6

Perhaps an issue in the Raspberry communication with the camera. it does look like some data is lost, maybe a driver or USB issue.

But again, green block artifacts are not what I expect if the issue is the Raspberry side. The camera outputs the h264 stream ready, the Raspberry just packages and forwards it to the computer. Maybe the camera doesn’t work well with USB 2.0 or is not getting the voltage it needs.

A lower frame size reduces both bandwidth and encoding load in the camera, which should solve both the issues I mentioned.

0 Likes

(Jacob) #7

@gyj Do you have a link or datasheet about the camera you are using?

0 Likes