BLUEOS + Pixhawk 1 reboot issue

Hi there,

I was using companion+pixhawk and there was no problem while doing reboot operation.

But now I upgraded the firmware of RPI to blueos(+pixhawk), the vehicle cannot reboot itself appropriately. When I reboot it, it turns on all the lights of vehicle and does not turn off. I have to replug the battery to solve the issue.

What can cause this problem?

Thanks for answers in advance.

Hi @elchinaslanli,

Are you restarting through BlueOS, or some other way?

I’ve previously reported an issue where restarting a Pixhawk through the BlueOS web interface successfully restarts the Pixhawk but then fails to reconnect to it until BlueOS is rebooted - it’s possible you’re running into the same problem.

I’ve found that restarting through QGroundControl tends to work fine, so where and how you’re restarting is relevant.

It might work to reboot using the MAV_CMD_PREFLIGHT_REBOOT_SHUTDOWN MAVLink command (with a 1 for the first parameter, and 0s for the other 6).

1 Like

I tried to reproduce the problem again, tried 10 times reboot with QGC, and 5 times with BlueOS just experienced 1 reboot issue this time with only BlueOS reboot.

If the problem occurs again, I will try to write with details.

1 Like