BlueOS faulty upgrade, reinstall Blueboat

Hi @mattcmgb -
What GPS issue were you encountering? We’ve had some limited reports of poor GPS performance, but think those were likely tied to hardware issues…

Hi @tony-white it was the last post on this thread. I haven’t had any gps issues but didn’t want to jump to v4.4 if there was an issue

Ah I see - no issues with 4.4.0 now. The problem at that point was that the ArduRover firmware was not ready for release, and causing other issues. Those have been resolved, and @FairweatherIT 's issues are suspected to be related to the GPS hardware itself, at least at the moment. I’ve upgraded to 4.4.0 but not yet done a deployment - but all should be good!

@tony-white, thank you for the solution to the problems I am having. I will try the new .lua in ~2 weeks since I am still on another task. I tried the ‘Simple Ping2 Survey Extension’ this tuesday (not yet in open water)… it did work fine…

@PaulBarter, thank you for the success and discussion. It will surely help when I get my hands on the BlueBoat.

Will keep you guys posted…

Hi @knarotama !!
So excited that you tried the extension out! Please share any feedback on that post, if you have any. I’m working to improve it - the next update will make sure logs are stored on the vehicle after a reboot… :sweat_smile:
Thank you all!

A post was merged into an existing topic: Alpha release: Simple Ping2 Survey Extension

Hi all -
If you’d like to flash an image that has the parameters for BlueBoat already loaded, this is the factory image we use. Using it may be more straightforward as it contains the lights.lua file and correct parameters already.

Sorry about this - I’ve just updated the forum settings to allow .lua file uploads, so this shouldn’t be necessary in future.

In case it’s relevant, the NavLight Lua script has now also been uploaded to GitHub, which is where any future official Blue Robotics Lua scripts are likely to go for the time being.

Hopefully in future we can support installing them as BlueOS add-ons, and we’re also planning to create a Lua management interface to improve the experience of creating and using them, but neither of those are available options at this stage.

@tony-white and @PaulBarter -

Thank you for solution. I just reinstall the BlueBoat with the link shared by @tony-white (v. 1.1.0) and the setup was easy.

Steps taken:

  1. Downloaded the BlueOS (link shared by @tony-white )
  2. Flashed the microSD card from the BlueBoat Raspberry Pi module with the BlueOS (#1) using Balena Etcher
  3. Pluged back the microSD card into the Rapberry Pi module of the BlueBoat… and then Turned ON the BlueBoat… and wait about several minutes until the BlueBoat stoped making any sound and the NavLight was blinking slowly.
  4. Accessed the BlueOS in the BlueBoat through the Base Station (Windows 11 Laptop was connected with the included USB-C cable to the Base Station)
  5. Accessed (blueos.local) from Browser and then upgraded the BlueOS to v1.1.1
  6. Opened Q Ground Control, it automatically detected the BlueBoat… continued with sensor calibration, checking motor directions, controller/joystick setup and back-up the parameters.
  7. At this step I think the BlueBoat is in good condition and ready for the water :sailboat:
1 Like