Home        Store        Learn        Blog

1:Qgroundcontrol video disabled, 2: camera tilt servo not working although setup has been made

Hello Bluerobotics Community,
I have two questions regarding cameras and gimbals.
I am setting up a raspberry pi usb camera right now. its the BlueRobotics USB wide lowlight camera. Onboard H.264, 1080p
I was able to use the camera yesterday and it was functional.
Today when I connected the camera to my Raspberry pi3b the video did not appear in QGC. Instead of the video the box said “Video Disabled”. I immediatly checked if I had the “disable when disarmed” setting on but I didn’t. In my windows computer it says ‘waiting for video’ instead of the “video disabled” message
Video Settings:
UDP h.264 Video Stream, Port 5600, 1.777777 ratio, low latency mode on, Disable when disarmed off
How can I fix this?
Second:
I am trying to make a camera tilt system. The servo I am using is MG90S micro servo. It is connected to the Pixhawk Main out Channel 8 and is assigned as such in the QGC camera settings. I have a pixhawk power module connected Is this how the servo is supposed to be powered or is there some other way?
Versions used
macOS Big sur
ardusub 4.0.3
QGc 4.0.5
pixhawk 4

Hi @VioletCheese,

Are you able to check the companion web interface to see if the camera is detected? The System page should have a ‘video’ item in the ‘Active Services’ section, and should identify your camera in the ‘Detected Devices’ section. The Camera page should show you the active camera and if it’s connected properly you should be able to change the video stream settings.

If the camera isn’t appearing then I’d suggest you try plugging it directly into your computer and seeing if it can detect it, otherwise the camera is likely broken/damaged.

If the camera is being detected but not in QGC then there’s either a streaming problem with companion (unlikely given it was working yesterday), or some kind of issue with QGC. I’d suggest updating companion if there’s an update available (use the System page on the web interface, latest version is 0.0.26), and possibly reinstalling QGC.

There’s some marginal possibility of this being a Mac permissions issue given it’s saying it’s Disabled rather than not connecting or whatnot, so maybe also worth checking your system preferences and seeing if there’s anything related to QGC that can or should be turned on (very much out on a limb here, and I haven’t had any issues like this on my Mac so it’s quite unlikely).

To quote myself:

The ArduSub connection diagram uses a power sense module connected to the pixhawk power port, for monitoring power usage and charge level of the battery, and then uses a 5V6A BEC via the SBUS position of the servo rail to power both the pixhawk and any connected servos.

hi @VioletCheese ,

In addition to @EliotBR 's suggestions, check the Video Source section in QGC’s General Settings.
It should show UDP H264, not Video Stream Disabled.

1 Like