USB camera not detected by the companion computer

Hi there! We are currently having problems on the USB webcam that we are using with the companion computer. We are using a two-camera setup using two USB cameras of identical models, one each for the top and bottom hull. This has worked before on our initial circuit tests prior to building the drone and we were able to transmit both video feeds to the topside using GStreamer.

However, after building the drone and connecting the wires of the bottom hull camera through the penetrators going to the top hull, the USB camera has stopped being detected by the companion computer. We have tried to plug this camera to a Windows 10 computer via USB and it still works, so we suspect it has something to do with the companion computer or any related settings, and not the USB camera itself. Any help in trying to get the camera detected by the companion computer would be appreciated. Thanks!

In another thread I’ve highlighted the fact that the RPi is REALLY sensitive to the cable shielding, particularly after modification - same symptoms:works on a laptop but not on the RPi. I’d suggest changing the internal cable for a high spec high speed shielded cable and keep the unshielded ends as short as possible.

1 Like

Hi there, @richard-rickett! Thanks for this. I’ve done some initial searches on the forums on what you’ve said regarding cable shielding and found some really helpful stuff. Will try what you said and replace the internal cable.

1 Like

Update. We have tried a solution from this post in the forums and it partially worked, having only detected the other device but as an audio device:

Any ideas why this could be the case?

Possibly the audio stream is less susceptible to interference ? But that’s just a guess

1 Like

Hi @yvesyves,

As @richard-rickett mentioned this is likely an issue with the RPi rather than a software problem. Beyond potential signal noise issues (e.g. due to insufficient shielding), the post you linked to also recommends trying an externally powered USB hub to ensure the issue is not that the RPi is unable to provide sufficient power to multiple cameras simultaneously. I would suggest trying that if possible.

It may also be worth disconnecting everything except the two cameras and seeing if they both appear in the web interface. If that works then it’s definitely not a software issue with detecting both, but unfortunately doesn’t narrow down whether it’s a signal noise or powering issue.

1 Like

To add a little - when I had the same issue, I tried using separate power to the camera, didn’t work so it had to be data loss. Tried a few cable types until I found one that worked !

1 Like

Hi! Thanks for your inputs on this. We only had a USB hub which was not externally powered and is what caused the RPi to detect the audio device.

We also tried this and had the same results as before, although we were already suspecting hardware issues when it happened.

We tried a last ditch effort in shielding the cables ourselves using aluminum foil before resulting to changing cables. We’re surprised that it worked! We covered the exposed wires of the camera with aluminum foil and after checking the web interface and the terminal, we confirmed that the camera is already being detected.

Thanks for both of your answers. It really helped us a lot. Cheers!