Topside and companion computer does not connect using a tether

Hi there! We recently bought a 50-meter tether online and tried to connect it to the topside and companion computers. We have used other UTP cables before and they work perfectly. However, after crimping both ends of the tether and trying it out, the web interface of the companion computer does not load and cannot be pinged through CMD. Additionally, only the tilting and compass of the Pixhawk can be seen in QGroundControl. As far as I know, 50 meters is less than the 100 meter limit of Cat5 and should work just fine. The Ardusub documentation also states that a tether interface board could be used but is not required for basic functionality. We just want to know, what may be the cause of this? We’re also thinking that both computers cannot provide the needed power to propagate the signal on such a long cable. Any help would be appreciated. Thanks!

Hi @yvesyves,

Our tethers are not guaranteed to meet the official CAT5 specifications, and it’s possible the specification doesn’t even apply underwater (there’s some recent discussion on both those points here). That said, 50 meters is unexpectedly short given within that discussion someone was able to achieve a 100Mbps link with ~80 meters of tether.

This is quite confusing. Generally pinging is the minimum functionality, followed by web interface connectivity (which generally avoid firewall issues), so the fact that pinging and the web interface aren’t working but it’s apparently successfully sending telemetry data is very odd. Out of interest,

  1. What software are you running on the Onboard (Companion) Computer, and how are you trying to ping it?
  2. When you used shorter cables, were you using the same command for pinging, and the same address for the web interface?
  3. Is it possible you’ve changed the IP address of the Onboard and topside computers, and are using an incorrect IP for the web interface / pinging / video configuration?

Hi there, @EliotBR.

Thanks for this. We’ve seen this topic in our initial searches, although haven’t got much time to get to it yet.

Please correct me if I understood the question wrong. Our companion computer is only running the companion computer image and nothing else. We used CMD on the topside to ping to test if the companion computer would respond.

Yes, we actually did cut the cable down to 15 meters and successfully pinged the companion and loaded the web interface.

We’ve also checked the network settings of the topside computer multiple times to ensure that its IP address is a static and tried to access the web interface at Unfortunately, only the shorter cable worked in both of our tests.

We’re currently suspecting a fault somewhere along the length of the cable, although it would be difficult to accurately find without any proper equipment.

If the cable has been cut, or pulled or bent excessively then one or more of the wires may be damaged. You can use a multimeter to try to find which wire has unexpectedly high resistance, but finding the exact location of a breakage may be quite difficult, especially if it’s internal.

That said, I still don’t understand how telemetry data is getting through if pinging and the web interface aren’t working. They use the same wires, so I would assume if there’s an intermittent connection or something then you may get telemetry trickling through, but in that case I would expect that the occasional ping would then get through as well.

1 Like