Home        Store        Docs        Blog

T100 Thruster with Blue ESC Acting Strangely on I2C Bus

(Luc) #1

Two of the T100 thrusters with built in Blue ESC that I have appear to be misbehaving on I2c, connected to a Raspberry Pi 3 (through an adafruit level shifter https://www.adafruit.com/product/757).

On connection of power and I2c the blue light often doesn’t turn on. After attempting to send I2c messages a few times to the Blue ESC, the light will eventually turn on. At this point, throttle commands can be sent successfully and the thruster responds. Occasionally it will randomly ramp up to a high thrust, without warning, caused by a I2c transaction (even when sent to a different address).

I tried to diagnose this with an ocilliscope, and during the times where the led is off, and the thruster is stuck in this ‘mode’, the I2c data line is pulled to ground (also breaking any other communication on the bus). I have tried flashing the firmware multiple times to both thrusters, and have tested with flashing different addresses.

This only is happening on our thrusters with the LEDs which poke further out of the enclosure (compared to the ones wth more diffused, wider covers). It would be great if I could sort this issue, as it renders these thrusters useless, with this amount of unreliability.

Thanks, Luc.

(Adam) #2

Hi Luc,

It sounds like the BlueESC is giving you trouble- email us at support@bluerobotics.com and we’ll get it sorted!


(Luc) #3

@adam I sent an email.