Home        Store        Docs        Blog

Relative positioning of jaws on newton gripper

(Etienne Demers) #1

Hi guys,

Finally got around to installing the newton gripper. Works well but the jaws either opens completely or shuts completely.

Is there a way to partially open the jaws?

Cheers,
E.

(Jacob) #2

@etienne try the _max_momentary functions on the joystick buttons

(Etienne Demers) #3

Hi Jacob,

I tried that and all other available options. Same results either fully open or fully closed.

Cheers
E

(Jacob) #4

Do you have a servo tester or oscilloscope? The pwm signal is velocity control. The gripper should be stationary at 1500pwm, and full velocity at 1900/1100.

(Etienne Demers) #5

I have a scope.

As I understood it, the gripper should only move when the button is pressed and not travel full. So I was a bit surprised it was behaving like this.

I will have a look at the settings for Servo 3 which I am using. Maybe the stationary pulse is not 1500pwm.

Cheers,
E.

(Deepak Jayan) #6

Sir,

I tried to install the newton subsea gripper in my ROV through pixhawk. It works but the jaws either opens completely or closes completely. I tried to check out for the options “max_momentary” and “min_momentary” as specified in the blue robotics documentation. But I couldn’t find these options in the latest version of ardusub i.e in ardusub version 3.5.4. All I could actually see were the options SERVOx_min, SERVOx_max, SERVOx_center, SERVOx_inc and SERVOx_dec. I tried all these options one by one, but couldn’t get the expected result. Can you please tell me how I can control these gripper jaws perfectly in the latest version of ardusub. Looking forward for your reply.

Thanking you,
Regards,
Deepak

(Etienne Demers) #7

I haven’t had time to progress further on this. Mine is either all open or all closed.

(Jacob) #8

@deepak, make sure you are using the latest version of QGC: https://www.ardusub.com/resources/downloads.html
the servo_max_momentary options are there, lower in the list than the other ones you mentioned.