Home        Store        Docs        Blog

New Basic ESC r3 on power supply (no batteries)


(Bart Arts) #1

Hi,

I’m hoping someone could help me:
I’m running a custom build of the BLUEROV2 with a 80V 60A power supply set to 19V ,getting up to 40A out of it, 50m cable, leaves about 15-12V during normal operation, which is enough for my use. This worked well on previous ROV’s with the r2 ESCs.
I ordered a new BLUEROV2, which came with the r3 ESCs preinstalled. Now with the new r3 ESCs The power supply shuts off because of OVP: I see the voltage spike up to 26V (where the OVP shuts it off, because I read the limit for the ESCs is 26V). So, I read up on the new ESCs: I believe they use regenerative breaking!
-Could this cause my problems? I couldn’t find any info on this for the older r2 ESCs.
-Is there a way to disable this feature in the new ESCs?
or
-is it safe to increase the limit on my OVP settings?

I think I connected everything identically to my previous setup. Triple checking the wiring now.

Thanks,
Bart


(Adam) #2

Hi Bart,

I believe you are correct, it appears the regenerative braking the is on by default in the new Basic ESC is causing large voltage spike than can trip the over current protection on you power supply. This is not normally an issue with a battery, but we’ve recently noticed sensitive power supplies can behave like this with a thruster running in air, and thus being braked exclusively by the ESC instead of water. The older R1 and R2 ESCs did not have this behavior.

We are looking into solving this by disabling all regenerative braking on the BLHeli_S firmware going forward, which is on by default. This feature cannot normally be disabled using a regular GUI programmer like BLHeliSuite, it will require some lower level firmware editing. In the meantime, yes, it is safe to increase the OVP limit on you power supply to keep it from tripping. The ESCs are designed to handle these large voltage spikes.

-Adam


(Bart Arts) #3

Hi Adam,

Thanks for the quick reply!
I did find here (http://intofpv.com/t-how-do-you-turn-off-active-braking-in-blheli) that the BLHeliSuite does have an option to do so, but I’m not sure if this setting is persistant, and if it works on your specific firmware. I might try it in the future, but I’m short on time for this project, so for now I’ll just up the OVP limit.

Just curious: was it on purpose / by choice that this feature is in the new ESCs, or was it always planned to disable it? I can’t imagine regenerative braking is as effective under water as it may be in air…

-Bart


(Adam) #4

Hi Bart,

BlHeli does have the option to turn of regenerative braking, but our ESCs run BLHeli_S, which does not have this option. With BLHeli_S, you can only turn off “Active Braking”, a different feature, and the “Damped Light” regenerative braking mode is always on with no way to turn it off. This feature was always planed to disabled, as it serves no purpose underwater.

-Adam


(Bart Arts) #5

OK, thanks for the info! Works great now by the way !


(Ferit Çakıcı) #6

Hi Adam,

I am experiencing the same issue of increased voltage at the input of ESC’s, which comes from “Regenerative Breaking” feature of BL_HELI_S firmware.

In my application, I am more concerned about other devices that are on the same power bus as the ESCs, like regulators, lights and more sensitive avionics. Although ESCs can handle high voltages, other devices may not tolerate this and burn due to their lower high voltage limits.

So, I really need the feature to turn off “Regenerative Breaking”.
I am looking to hearing from you…

Best wishes.
Ferit.


(Bart Arts) #7

I don’t know your setup, but perhaps this option is useful to you:
I separated power to the motors and avionics to avoid these dangers.

I use the phantom tether as normal ethernet cable with POE to power the pixhawk (through the rail, also for camera servo) and raspberry PI. This involved removing the phantom boards on either end, and replacing them with a POE switch and POE->5V+Ethernet adapter in the ROV. I disconnected the wires that would normally power the pixhawk through the power module, but left the lines for V/A measurements intact. Works like a charm! Only the lumens are on the same power rail as the motors, but they seem to have no problem other than dimming when you max out the power supply.

Another advantage to this setup: you can keep your electronics powered with the motors safely powered off (no accidental arming).


(Adam) #8

Hi @FerdiCakmak,

This voltage spike is only significant when testing a thruster in air and almost all braking in being done by the ESC. We’ve tested for voltage spikes with an oscilloscope with a thruster running underwater, and there the water stops a thruster almost immediately so there is no braking to be done by the ESC. Underwater in actual conditions, the voltage spike from the ESCs is significantly reduced, and is unlikely to affect other instruments. That being said, we are working on disabling it anyway, but there are some hurdles to overcome. It looks like we need to compile our own fork of BLHeli_S to do this.

-Adam


(Ferit Çakıcı) #9

Hi @adam,

Is there any progress with disabling “Damped Light - Regenerative Breaking”?

Best Wishes.
Ferdi.


(Adam) #10

Hi @FerdiCakmak,

With the help of the BlHeli developer, we were able to generate a version of the BlHeli_S firmware with the damped light setting disabled. However, this did not solve the behavior, and resulted in more violent braking force upon direction reversal than before. This was likely due to the interaction between BlHeli’s lack of a dead zone and running it bidirectionally without braking. BlHeli was not intended to be run in this way, and unfortunately it would take a more fundamental re-working of the firmware to make this work well- an entirely new firmware would likely need to be developed.

The active braking only has noticeable side effects when the thruster is run in air, and with specific types of power supplies. Underwater and especially with a battery, there is no issue, therefore we do not see a need to develop an entirely new firmware at this time.

If any possible extremely short and small voltage spikes are a concern for your particularly sensitive equipment, I recommend using either a different ESC or or adding a power filter.

-Adam