Installed Waterlinked A50 - Pi / Navigator don't boot up

After installing A50 DVL the ROV would not boot up. Looking at Pi LEDs when powering on noticed a sequence that after about 6 to 10 seconds both LEDs would go off then red power LED would come on and never finish booting up. Tried re-flashing SD card with Blue OS but same result. Then bought new Pi 4 computer re-flashed SD again and tried. It came on so reassembled everything hook up and went back to no boot. Tried unhooking things and repeatedly powering on / testing and for some reason every once in a while would boot up but would not repeat. Bottom line is I discovered that if DVL power was disconnected it boots up every time.

With some further investigation I found that if I use a relay to apply power instead of direct connecting to battery with XT connector it will boot up every time with DVL connected.

Anyone experience anything like this or have any idea what the real issue is? I would like to see if I can resolve issue before trying to implement a work around.

Hi @dtrail,

It should be possible to check that the DVL is starting up correctly by connecting it directly to your computer and seeing whether its web interface is accessible.

From your description it sounds like there might be some kind of power issue, in which perhaps the DVL is defective? It doesn’t make sense for a DVL to draw too much current for the battery to handle, so either there’s a short circuit somewhere or perhaps the DVL has not been connected correctly.

Can you describe how you’re connecting the DVL to power and to the vehicle? :slight_smile:

Power to DVL is from battery terminal strips per instructions. Investigated using a bench power supply and it doesn’t appear to have inrush current showing on amp meter 1.1 amps on power up at 14.5 v. If I turn on power supply with it’s power button won’t boot up. If I leave power supply on and disconnect and reconnect lead wire it boots up.
If I use relay to connected battery it boots up but if I connect via the XT90 connector won’t boot.
If I leave XT90 connected and disconnect battery positive or negative lead wires via banana connector and reconnect it boots up.

DVL is connected and working properly. I put a relay in to turn on DVL with controller button after connection to ROV and works.

I have solution but still puzzles me.