Home        Store        Docs        Blog

Br2 temp sense n switch install


(Kaos) #1

Hi all,

So i have a BR2 and have purchased the temp sensor and switch. The switch, i want to turn the power off so i can load a battery and vacuum test, then turn battery on. The doc for the switch does not give me a clue as to where to wire to in rov for this purpose.

I have bought the temp sensor only and have the same issue as above but with the complication of wondering if i needed other components? Also wondering if i need to add code for it to work through BR2, or is it set to go

Am i missing something in the docs?

All help welcome


(Adam) #2

Hi Kaos,

The Switch is not actually meant to be a drop in accessory/upgrade for the BlueROV2. I apologize if this was not made apparent in the store page and documentation. Its designed to switch signals for a micro controller input or to turn on and off lower power devices in other projects or vehicles. It has a maximum current capability of 5A- for comparison, the the BlueROV2 can draw a constant load of over 60A, with spikes over 100A. It is not possible to switch the power on and off in the BlueROV2 with this.

The Celsius temperature sensor is not quite yet a drop in upgrade for the BlueROV2. To hook it up, unplug the Bar30 from the I2C port on the Pixhawk, and then plug both senors into the I2C splitter board which came with the Pixhawk accessories package that was included with the BlueROV2. The board then plugs into the Pixhawk I2C port. However, the Ardusub software does not quite yet support the Celsius, once the necessary drivers are added in a few weeks it will show up the same as the Bar30.

-Adam


(Kaos) #3

Hi Adam

Thanks for clearing those points up for me. Temp sensor is important for the work I do with rov so will happily wait for drivers.

As for the switch, I was hoping that it would sort out the problem of having to vacuum test with battery in and powered up. Doesn’t seem right vacuum testing first then opening batt tube to install batt after the test.

I can only source 6000mah batteries in my country as lipo’s can’t be sent by air to NZ. Hobbyking have them available in Australia but won’t send to NZ. Damn frustrating when I really need as much bottom time as I can get.

Maybe using the switch with a relay could be a solution? Would appreciate Rusty and the team working out a solution for this, when they have time…


(Adam) #4

Hi Kaos,

I understand the reservations you have about reopening and closing the battery tube up again after doing a vacuum test. The vacuum test is more designed to make sure that everything is in place, penetrators are tight, and no o-rings are missing. Once an enclosure has passed a vacuum test, we have never had any problems with leaks after opening it again to put in the battery. As long as the o-ring is properly lubricated and appears to have a tight seal on the tube with no debris, nothing should happen to compromise the seal between a vacuum test and placing the battery.

That said, we are working on a solution for remote full power switching, though is is still a number of months away. In the nearer term, I have some good new for you- in about a month we will have an 18Ah battery available for the BlueROV2, which we will definitely be able to air ship to New Zealand! How does tripling your bottom time sound?

-Adam


(TCIII) #5

@Kaos,

I have been doing extensive vacuum testing of both the BR Battery WTC and the Electronics Tray WTC.

I have done the vacuum testing without a battery in the Battery WTC or the Electronics Tray in the Electronics Tray WTC and have maintained a 540 mm Hg vacuum in both WTCs over a period of 20 hours with only a loss of 10 mm Hg due to cutoff valve leakage.

In my opinion if your cable penetrations are not leaking and you have verified the required BR vacuum level, then taking the Battery WTC End Cap on and off to recharge the batteries will not compromise the vacuum seal of the WTC.

Also, I have been able to fit a pair of Turnigy nano-tech 5ooo mah 3S LiPos (my custom BlueROV2 is using T100 BlueESC thrusters) into the Battery WTC. The LiPos are stacked one on top of the other and a Velcro strap is used to hold the batteries together as well as the Y adapter to run the batteries in parallel. Though I did have to make a longer battery connector cable than is supplied with the BlueROV2 kit.

Bottom line here is that you might be able to fit two 5000 mah 4S LiPos into the Battery WTC and run them in parallel for a combined battery of 10,000 mah.

Regards,

TCIII AVD


(Kaos) #6

Hi all,

Thanks for the feed back. It is great to hear the results of people with experience with BR2. Your comments on vacuum testing gives me confidence.

As for the battery supply issue, awesome news that I will be able to triple my bottom time in the future. And in the mean time, TCIII solution will help immensely.

Buying open source technology was the best decision for a person living at the bottom of the world.

Thanks to all


(Mark) #7

Hey Kaos,
I managed to buy 4 Multistar 4S 10000mAh Batteries from Hobbyking about a month ago, they sent them by sea freight from Australia, but they took a couple of weeks though.
Just thought I would let you know.

Thanks
Mark


(Kaos) #8

Thanks Mark,
Sorted batteries now so up and running. :relaxed:


#9

Hello,

I don’t want to open a new topic so I try to post here.

I got a Celsius sensor (the penetrator version), that I plugged to the I2C splitter provided together with the BAR30 sensor. I can see the depth (so the splitter seems to work), but the Celsius does not seem to be recognised. When I look in the setting or the MAV explorer, I can see scaled pressure and scaled pressure2 but not the number 3… I just downloaded today the last version of QGC and indeed the “high res temp” stays empty.

Because as some of you know by know, I am a bit out of my domain with these technological things (but working hard to improve my skills on this front), I am wondering if I should have done something else (the ARDUINO code on the Celsius sensor page looks pretty scary to me and I am not sure where I should start if I need to play at this level…

Sorry for always asking very basic questions, but thanks a lot for the help.

Frederic


(Jacob) #10

Hi Frederic, don’t worry, you do not have to write any code!

Can you please tell me what version of ArduSub your ROV is running? You can find this in QGC on the Summary tab of the Vehicle Setup page.


#11

Hi Jacob,

Maybe here is the problem… I don’t see the “frame tab”…

Also, would this issue also explain some connectivity issue we have. Until now disconnecting the battery and reconnecting it was enough to regain connection (or sometime if connection was lost during the dive, it only lasted a few seconds before recovering by itself, but today at sea, it was impossible to connect the ROV, and now that we are back at the hotel, it worked quite smooth… (at sea, I tried to get a ping, but it was really impossible to get any connection to the ROV, can the BlueROV2 be seasick?).
Thanks a lot for your help, hopefully tomorrow we can get it in the water and swimming…

Cheers,

Frederic

P.S. I tried to explore the ArduSub update thing from your september message and actually I cannot open a webpage directly from 192.168.2.2:2770/ so I am wondering if I need to do the major update with the Raspberry SD card, etc… We bought the ROV in July, but in Japan so maybe it was a model that was shipped before June 2017…
Also the QGC often seem to panick a bit and keep repeating “MYGCS 255 heartbeat lost”… I am not sure if this is related or independant…
Would this explain all the issues?


(Jacob) #12

Ok Frederic, you need to update the software on the ROV (ArduSub on the pixhawk, and companion on the Raspberry Pi). You will need to do the update according to the instructions here.

After the update, you will see the frame tab in QGC, and the depth sensor should be automatically detected.

The communication issues and heartbeat lost are unrelated to the updates. It sounds like a physical connection issue. Please make sure that the topside Fathom X tether interface board has sufficient power, and that the tether conductors are well-seated in both the topside and rov Fathom X boards.


#13

Thank you very much for the rapid answer and instructions!