Home        Store        Docs        Blog

Trouble dimming R1 Lumen light with servo pulses


(Jean-Christophe Sicotte-Brisson) #1

Hi there,
I have been able to get the Arduino IDE test code running from the Lumen Light documentation page (simply turning Lumen on with a 1700 microseconds pulse). However, when I add a delay, a servo pulse of another length (I’ve tried 1100, 1200) and another delay, the light doesn’t seem to flicker on and off, like I thought it would, but its brightness slowly oscillates without really following the delay time spans, and it definitely stays brighter than what should be a 1100 or 1200 pulse.
So I feel like something is going on, because it’s not staying at a set brightness, but the way my Arduino sends the pulses seems wrong. I tried different delay periods, because I thought at first that 1000 milliseconds was too slow for the Lumen lights to dim down, but I went up to a 10 seconds delay between each servo write and the same issue occurs. Another weird thing is that I added hardware serial writes across the code and nothing appears on my serial monitor (I’ve tested it before and after with other codes and its working, I just do not know why it looks like nothing is going through the serial when I run this particular code). Here’s my code, even though it’s basically just the test snippet with an added delay and serial prints:

*I can’t get the preformatted text to work?? sorry!

#include <Servo.h>

byte servoPin = 9;
Servo servo;

void setup() {

Serial.begin(9600);
Serial.println(“yo”);

servo.attach(servoPin);

//servo.writeMicroseconds(1100); // send “off” signal to Lumen light
}

void loop() {
Serial.println(“turning off”);
servo.writeMicroseconds(1200); // Send signal to Lumen light
Serial.println(“done, its off”);
delay(3000);

servo.writeMicroseconds(1800); // Send signal to Lumen light
Serial.println(“turned ON”);
delay(3000);

}


(Jacob) #2

Can you post a video of the behavior you are observing? You should send a signal of 1100 (not 1200) to turn the light off


(Jean-Christophe Sicotte-Brisson) #3

I ended up figuring out! I think the Arduino IDE was the problem. After trying to figure out the problem for a while, I restarted the program and everything was ok. Weird software… Thanks a lot for the reply